Some OLE objects and embedded images do not plot from AutoCAD

Autodesk Support

Feb 19, 2025


Products and versions covered


Issue:

Users reported that when plotting a drawing that contains OLE objects from AutoCAD, one or more of them do not print. This happens when plotting or publishing to a physical printer or PDF. The following may also occur:
  • The missing images may be visible in model space, layouts, and plot preview,
  • The image may appear to have been removed from the drawing after saving, closing, and reopening the DWG file.
  • A different image may be missing with each plot. 
  • Images may reappear in a PDF after zooming in and out, or clicking on the empty space. 
  • The following warning may be shown: "Warning: Failed to rasterize image for plot."
Warning: Failed to rasterize image for plot
 

Causes:

  • Resolution differences between the OLE output versus the printer driver.
  • Low printer driver resolution setting.
  • Page orientation rotated (portrait or landscape) in AutoCAD but not in the printer driver.
  • Insufficient system resources either on the workstation or the plotter. 
  • The machine only has an integrated graphics card.
  • Objects created by non-Autodesk Products. 
  • Large amount of information copied from another software (Word, Excel, and others) and pasted into AutoCAD.
  • Outdated plotter driver.
  • PDF viewer cannot display objects. 
  • Antivirus/Firewall blocking AutoCAD.
  • Missing updates for AutoCAD and its specialized toolsets.
  • Non-Microsoft network environments. 

Solution:

Change the Plot Quality setting of the affected OLE objects

  1. Select the OLE object.
  2. Open the Properties window.
  3. Change Plot Quality to High Graphics.
Note: Any setting may make a difference but usually High Graphics is best.

Increase the printer resolution

  1. Enter PLOT on the command line to open the Plot dialog box.
  2. Select the printer-plotter and click Properties... next to the name of the plotter.
  3. On the Device and Document Settings tab, choose Custom Properties, and click Custom Properties....
  4. Increase the resolution (DPI) where possible (options vary for each device/printer driver; check specific printer documentation for assistance):
    • For AutoCAD PDF drivers, increase DPI for Vector Image Quality and Raster Image Quality.
    • For physical printers/plotters, adjust Detailed Settings > Print Quality, when available.
The Image shows Device and Documents Settings.

The image shows how to change Print Quality for physical printers/plotters.
 

Decrease the printer resolution

  1. Enter PUBLISH on the command line to open the Publish dialog box.
  2. Click Publish Options.
  3. Reduce DPI for Vector Image Quality and/or Raster Image Quality.
  4. Confirm with OK.

Resize the OLE object

Scale the OLE object up or down slightly. It may be necessary to use MS Paint to edit the image.

Lower the page size

Test using a smaller page size so that fewer system resources are used.

Create an image from the original

  1. Use the Windows Snipping Tool or other image capture software to create a copy of the image. 
  2. Delete the original image from the file. 
  3. Attach the newly snipped image.

New drawing

  1. Create a drawing.
  2. Insert the existing drawing, including the embedded OLE-object, into this new drawing.

Existing drawing

  1. Remove the OLE-object in the existing drawing.
  2. Insert the OLE-object as a raster image reference, using command IMAGEATTACH.

Clean Windows and AutoCAD Graphic Cache Temp Folders.

  1. Clean Windows TEMP Folder. See How to delete temporary files in Windows.
  2. Clean AutoCAD Graphics Cache Folder. See How to address display issues by clearing the graphics cache.

Objects were created by non-Autodesk software

  • If objects are contained within a block, EXPLODE the block and try printing.
  • Create an object in the drawing that does print, use MATCHPROP to match the properties the new object. 

    Make sure that the machine has a dedicated graphics card

    See: Certified Graphics Hardware.

    Update Plotter Driver

    Check the website of the plotter manufacturer, to get the recommended driver for the plotter under the current operating system. See: How to acquire the appropriate printer driver for AutoCAD.

    Antivirus or Firewall may be blocking the software, add an exception to discard Antivirus as root cause.

    More system troubleshooting

    • Test a different printer.
    • View the PDF in a different PDF viewer. 
    • Increase plotter memory.
    • Send the plot to a device with more memory.
    • Increase swap file size on the workstation.
    • ​Set the plot device driver to Process in Computer.
    • Copy a smaller amount of information (spreadsheet cells, text content, and other data) from the source software.
    • When plotting to a network environment, try plotting to the local drive instead. 

    More troubleshooting

    • Download and install the latest service pack and any hotfixes for your AutoCAD software. See Install Updates, Add-ons, and Enhancements.
    • If custom settings have been added to AutoCAD, try How to reset AutoCAD to defaults.
    • If a reset does not help, do a clean-uninstall and reinstall of AutoCAD and test without adding the custom settings back into AutoCAD. 
    • SET BACKGROUNDPLOT to 0
    • If the shade plot settings are set to be hidden in the viewport properties menu, under Misc section change the shade plot hidden to As Displayed

    Products:

    AutoCAD Products;


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