Repair or reinstall a corrupt AutoCAD installation

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

Your AutoCAD software fails to launch or doesn't work as expected.

Causes:

Your problem has many potential causes. This article focuses on corrupt or incomplete product installation.

Solution:

Determine whether you can repair your software or must reinstall. Before resorting to a reinstall, try these repair methods: 

  • Reset the menu system 

Problems with the AutoCAD menu system can occur when the Customize User Interface (CUI) isn't working normally. A prime symptom of CUI failure is unresponsiveness to Ribbon selections. If you suspect a problem with the menus, try resetting or restoring the CUI. To learn more, see. How to reset the CUIx in AutoCAD, or view How to Reset the CUIX

  • Reset options to their default values  

Resetting the AutoCAD options can be fast and effective. If you want to keep your custom values, back up your settings before the reset. To learn more, see How to reset AutoCAD to defaults, or view How to Reset AutoCAD

  • For AutoCAD 2021 and earlier, restore missing or corrupted support files by running the AutoCAD installer in maintenance mode

  1. Go to the Windows Uninstall control panel.
  2. Select AutoCAD and click Uninstall/Change.
  3. In the AutoCAD installer, click Repair or Reinstall.
  4. Follow the instructions given.  

If these methods don't restore your software, you may need to reinstall. Perform a clean uninstall to be sure not to carry forward any vestige of corruption into your new installation. See Perform a Clean Uninstall.

Products:

AutoCAD Products;

Versions:

all;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support