启动 Autodesk 软件时显示“应用程序无法正确启动 (0xc0000XXX)”

Autodesk Support

2024年11月20日


涵盖的产品和版本


问题:

Autodesk 软件无法启动,并显示以下错误消息:

acad.exe - 应用程序错误

应用程序无法正确启动 (0xc0000142)。请单击“确定”关闭应用程序。

应用程序无法正确启动
 

powershape.exe - 应用程序错误

应用程序无法正确启动 (0xc0150004)。请单击“确定”关闭应用程序。

powershape.exe - 应用程序错误
 

其他可能的错误代码包括但不限于:

  • 0xc0000005
  • 0xc000007b
  • 0xc0000142
  • 0xc0000005

原因:

可能的原因可能包括但不限于以下几点:

  • 注册表项不正确。

  • 受到广告软件或恶意软件干扰。

  • 受到安全软件干扰。

  • 存在冲突的程序或进程。

  • Microsoft Visual C++ Redistributable 出现问题。

  • 缺少产品更新。

解决方案:

Reinstall Microsoft Visual C++ Redistributable

请参见如何从 Autodesk 软件安装软件包重新安装 Microsoft Visual C++ 运行库

 

安装最新软件更新

转到 Autodesk Account 页面或 Autodesk Access 应用程序,并确保应用了最新更新。

 

查看 LoadAppInit_DLLs 注册表项

LoadAppInit_DLLs 注册表项应设置为 0,但其他程序可能已更改其值。

  1. 在键盘上按 Windows + R 以调出“运行”窗口。
  2. 输入 REGEDIT 并单击“确定”。
  3. 在注册表编辑器中,导航到:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows\LoadAppInit_DLLs

 LoadAppInit_DLLs 注册表项

  1. 双击 LoadAppInit_DLLs 的“数据”列中的值。

  2. 在“编辑 DWORD”对话框中,将“值数据”设置为 0。

LoadAppInit_DLLs DWORD

  1. 关闭“注册表编辑器”。

  2. 重新启动计算机,然后再次重新启动 Autodesk 软件。

有关 AppInit_DLLs 的详细信息,请参见 Windows 7 和 Windows Server 2008 R2 中的 AppInit_DLLS


警告!
如果由于不正确编辑 Windows 注册表而产生问题,可能导致计算机操作系统不可用。Microsoft 在 Microsoft 知识库中为您提供了大量有关注册表的重要信息。 请按照 Microsoft 文章如何在 Windows 中备份和还原注册表和相关解决方案如何备份系统注册表中所述,为操作系统备份注册表,然后再使用 Microsoft 注册表编辑器,使用风险自行承担。Microsoft 注册表编辑器中的“帮助”主题内也包含了其他关于注册表的信息。

 

删除来自广告软件或恶意软件的堵塞

查找并卸载以下任一项:

  • Search Protect(广告软件)
  • SW-Booster(广告软件)
  • SmartBar(恶意软件)
  • iLivid Toolbar(恶意软件)
  • PerformanceOptimizer(恶意软件)

 

删除来自安全软件的堵塞

查找并卸载以下任一项:
  • BeyondTrust PowerBroker
  • BeyondTrust Profile Loader
  • BeyondTrust Monitor Service
  • Zemana AntiLogger
  • Digital Guardian
注意:如果删除其中一个程序后,您的程序可以正常启动,则再次尝试重新安装该安全程序。如果再次发生冲突,请联系该安全软件供应商。

 

识别并解决其他软件冲突

使用 Microsoft Autoruns 实用程序识别可能干扰 Autodesk 软件的项。例如,NVIDIA 驱动程序和 Adobe Acrobat 9 Pro Extended acapture64.dll 或 acapture32.dll。
  1. 下载并安装 Autoruns。

  2. 提取 Autoruns.zip 的内容。

  3. 运行 Autoruns.exe。

  4. 启动 Autodesk 软件。

  5. 在 Autoruns 窗口中,选择“AppInit”选项卡。

  6. 在“AppInit”选项卡上对每个 DLL 文件执行以下步骤,找出冲突的程序:

    1. 使用显示的路径,在计算机上找到 DLL 文件。

    2. 重命名 DLL 文件。

    3. 尝试启动 Autodesk 软件。

      • 如果软件无法启动,请恢复 DLL 文件的原始名称。

      • 如果软件可以启动,即找出了冲突的程序。确定是否将其卸载。

 

产品:

Fusion、所有桌面产品


此信息是否有用?


需要帮助?请求助 Autodesk 助手!

助手可以帮助您找到答案或联系支持人员。


您享有什么级别的支持?

不同的固定期限使用许可方案提供了不同级别的支持。了解您的许可方案提供的支持级别。

查看支持级别