Search function in Inventor Content Center Library managed by Vault does not work

Autodesk Support

Jun 6, 2024


Products and versions covered


Issue:

The search function in an Inventor Content Center Library does not work.
When using the "Place from Content Center" option in Inventor and searching for any string, it shows no results if the Library is managed by Vault.
User-added image

Causes:

One of these or both could be the cause:
  • SQL Server:
The Installation Requirements for Vault require specific features for the Vault SQL Server instance to allow full-text search in Inventor Content Center Libraries managed by Vault.
The required Feature is "Full-Text and Semantic Extractions for Search".
  • ADMS Console:
For the Library is the function "Enable Full Text..." not activated.


 

Solution:

  • SQL Server: 

  1. It is to check that this SQL Server feature is installed for the Vault SQL Server instance
  2. Start the SQL Server Setup from the SQL Server media
  3. If SQL Server is installed from the Vault Server start the Setup from: ....\3rdParty\Sql2017ExpressAdv\x64.
  4. On the SQL Installation Center run New SQL Server stand-alone installation or add features to an existing installation.
  5. Run through the setup and select the Vault SQL instance (AUTODESKVAULT) on "Installation Type.
  6. On "Feature Selection select "Full-Text and Semantic Extractions for Search" 
SQL Server add function Full text search
  1. Finish the installation
 
  • Vault Server:
  1. Start the ADMS Console
  2. Expand the folder "Libraries".
  3. Right-click on the Library.
  4. Enable the function "Enable Full Text" option.
Vault Server activate Full TextFull text is enabled
 

Hint:
When the Vault Server function "Enable Full Text.. " is gray, then is it update the Customer Content Center in Inventor. Follow the steps in link: How to migrate customized Content Center Libraries managed by Vault Server (autodesk.com)

Products:

Inventor Professional; Vault Basic; Vault Professional; Vault Workgroup;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support