RPC content in 3D views are missing or appear as boxes in Revit

Autodesk Support

Mar 13, 2025


Products and versions covered


Issue:

RPC (Rich Photorealistic Content) Plantings and Entourage in 3D Revit views appear as boxes or are missing. This may happen only on some computers.


RPC Plantings and Entourage in 3D Revit views appear as boxes.
 

Causes:

The render appearance for the RPC family isn't set properly.

Solution:

To resolve this behavior in the family editor:

  1. Open the family in the family editor.
  2. In the Family Types dialog, under Identity Data, click Edit next to Render Appearance.
  3. Select the appropriate render appearance.
Note: It may be necessary to first choose a different render appearance and then reset to the correct one.
 
Render Appearance library dialog in Revit
  1. Click OK.
  2. Save the family. This will update the family in your family library.
  3. Reload the family into the project.

 

To resolve this behavior within the project:

  1. Select the family in a project view.
  2. In the Properties dialog, click Edit Type.
.RPC families' Type Properties window in Revit
  1. In the Type Properties dialog box, click Edit next to Render Appearance.
Render Appearance library dialog in Revit
  1. Select the appropriate render appearance.
Note: It may be necessary to first choose a different render appearance and then reset to the correct one.
  1. Click OK. This process will not change the library copy of the family.

 

If the Render appearance dialog still doesn't display anything:

  1. Download the ArchVision Dashboard from the following link: ArchVision.
  2. Install ArchVision and start it.
  3. Click Plug-ins / Software to install the RPC Plug-in for Revit. This should allow you to see RPCs instead of gray boxes. 

 

If the preceding steps fail to resolve the issue:

  1. Audit the model.
  2. Try to create a 3D view.
  3. Make sure that the latest build of Revit is installed: How to tie the Build number with the Revit update
  4. Try to repair Revit from the Windows Control Panel.
  5. Perform a clean uninstall and Reinstall of Revit following the steps in How to complete a Clean Uninstall of Revit products.

Products:

Revit Product Family;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support