"[Filename] references Revit add-ins that are not installed" error opening Revit cloud model

Autodesk Support

Apr 2, 2025


Products and versions covered


Issue:

  • When opening a Cloud Model in Revit, a message similar to the following appears.

Missing Add-ins

<file name>.rvt references Revit add-ins that are not installed.

References Revit add-ins that are not installed.

  • Journal entries similar to the following will be recorded preceding the message:
' 1:< SLOG $******** YYYY-MM-DD HH:MM:SS.SSS >WSConfig
' 1:< ISkyscraperClient not registered
  • Other error warning may appear:

Missing add-ins

Revit cannot load <file name>.rvt because the add-in that provides that resource is not installed

Missing add-ins Revit cannot load <file name>.rvt because the add-in that provides that resource is not installed

Causes:

  • Corrupted Revit Cloud Worksharing add-on installation.
  • Third party add-on interfering with the Revit Cloud Worksharing add-on.

Solution:

Update Revit

If Revit is not updated to latest version update to latest build: How to keep Revit updated

Disable Add-ons

See the following article for information on how to Check if add-ons are causing unexpected behavior in Revit.

Reinstall Cloud Component

See the following article for information on How to reinstall the Revit Cloud Worksharing add-on.

Linking

If encountering this error when linking within a cloud model, see the following article: "Revit cannot load {File} because the add-in that provides that resource is not installed" loading link in Revit cloud model

Products:

Revit Product Family; Revit Cloud Worksharing; BIM 360; Construction Cloud;


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