Delay, freeze, or crash, when inserting a block or drawing in AutoCAD Products

Autodesk Support

May 17, 2024


Products and versions covered


Issue:

User reported that when trying to insert a drawing or block into a drawing in AutoCAD, the program shows a delay, freezes, or crashes.

Causes:

  • AutoCAD is not up-to-date.
  • Many blocks in the drawing.
  • The AutoCAD profile was migrated from a prior version.
  • Plug-ins are loaded in AutoCAD and have malfunctioned.
  • Drawing is not healthy.

Solution:

Do one or more of the following:

Missing updates

Corrupt file

  • Repair the drawing (see How to repair corrupt AutoCAD files). In particular, use the RECOVER command to open the file, the PURGE command to remove unused data (leftover block definitions), -PURGE > RegApps to purge registered products in drawing and AUDIT.


Many block definitions

  • Disable block thumbnails on the Ribbon Gallery by typing in GALLERYVIEW and setting it to 0 (zero).
Note: To still have an overview of blocks when inserting them in the drawing, use the Design Center (DC command).

Clear recent blocks

  • For AutoCAD 2020 and newer:
    1. Clear the recent blocks from the Blocks palette by typing in BLOCKMRULIST and setting it to 0 (zero).
    2. Keep the Blocks palette closed and use the CLASSICINSERT command instead of INSERT.

Corrupt profile

Plug-in (s) that has malfunctioned

  • Unload the plug-in.
  • Reset AutoCAD to default.
  • Reload the plug-in.

For Autodesk Civil 3D

Products:

AutoCAD for Mac; AutoCAD LT for Mac; AutoCAD Products;


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