Excessive system memory usage causing slow performance or crash in AutoCAD Products

Autodesk Support

Mar 18, 2025


Products and versions covered


Issue:

While using AutoCAD, the program uses up most of the available memory on the system. This may happen while opening or saving a file, or while working in one or more open drawings. It could also happen only on specific files or on any file.

  • As a result, program performance and even general system performance becomes poor and sluggish.
  • Fatal error messages on the screen
  • AutoCAD may eventually freeze, requiring the acad.exe process to be terminated in the Windows Task Manager.
  • If the excessive memory usage happens when saving, it may occur after one save or it may be progressive with each save using more RAM. Eventually the drawing becomes impossible to work in and the program hangs and stops responding.

Causes:

There are several known causes:

  • Large number of annotative objects present in a drawing.
  • General file corruption.
  • Antivirus blocking AutoCAD or AutoCAD components
  • Missing user permissions.
  • System requirements to run AutoCAD not being met.
  • Graphics driver conflict.
  • Missing AutoCAD updates.
  • Corrupt user profile.
  • Missing or pending Windows 10 or 11 updates.

Solution:

Do one or more of the following:

Products:

AutoCAD Products;


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