Ribbon or Toolbars are missing, blank, disappear in AutoCAD Products

Autodesk Support

Feb 20, 2025


Products and versions covered


Issue:

Users reported that after starting up the AutoCAD or during its use, the ribbon, status bar, or other toolbars are missing, blank, empty, or have disappeared. Also, a message may appear that states that the customization file (*.cuix) cannot be located.

Note: The issue can apply to other AutoCAD-based software (for example Civil 3D) or any AutoCAD toolset.

Causes:

There can be multiple causes for this issue:

  • Clean Screen is toggled on.

  • The ribbon is turned off, set to autohide, or undocked.

  • Toolbars are turned off.

  • The status bar is hidden.

  • AutoCAD workspace has not been selected or has changed.

  • Incomplete or faulty AutoCAD installation.

  • Addition of 3rd party add-on. 

  • The directory path to the location of the *.cuix file (acad.cuix, acadlt.cuix, etc.) is missing from Support File Search Paths in OPTIONS.

  • Customization (*.cuix) file is corrupted or not installed properly.

  • Antivirus blocking access to the toolbars or ribbon working files or folders. 

Solution:

Follow the simple Step-by-step guide in the following link: Troubleshooting Guide "Ribbon or toolbars are missing, blank, or disappear in AutoCAD".

Alternatively, try the following suggestions one by one. (Preferred methods in order):

Turn on the ribbon and dock

  1. The ribbon can be closed or turned off. To turn it back on, type RIBBON on the command line.

  2. Check to see if the view mode of the ribbon also needs to be adjusted. Click the cycle button to the right of the ribbon tab to cycle through the panel views.

Icon of Show Full Ribbon

  1. Dock the ribbon by dragging and dropping it above the drawing area if it appears as a floating palette. 

Dock bar to move the palette window
Note: If the undocked ribbon cannot be moved, the user interface may be locked. Change the setting of the LOCKUI (System Variable to 0 (zero), which will unlock all. 


Turn off the Clean Screen feature

The Clean Screen feature maximizes the drawing area by hiding the ribbon, toolbars, and palettes.

  • Press CTRL-0 (zero) to toggle the Clean Screen setting.

Note: If the command line says CleanScreenOn, it is already off. Press CTRL-0 again to turn it off. 

Alternatively, look for the icon in the status bar at the bottom right. 
 

Feature helps to maximize the drawing area

Turn on the status bar

On the command line, type STATUSBAR and set the value to 1.
 

Turn on toolbars

  1. On the command line, type MENUBAR and set the value to 1.

  2. Click the Tools > Toolbars menu.

  3. Select the desired toolbars to turn them on.
     

Select or reset the current workspace

  1. On the Status bar, click the drop-down arrow next to the Workspace gear icon.

  2. Select a workspace or switch to a different one.

  3. If needed, switch back to the desired workspace. The act of changing workspaces and back can restore it.


Look for the ribbon or toolbar at the edge of or off-screen

Verify the following:


The directory path to the location of the *.cuix file (acad.cuix, acadlt.cuix, etc.) is missing from Support File Search Paths in OPTIONS

  1. Locate the *.cuix file that AutoCAD should be using. The default location is C:\Users\<username>\AppData\Roaming\Autodesk\AutoCAD 20xx\Rxx\<language>\Support.

  2. If that path is missing from the Support File Search Path section on the Files tab of OPTIONS, use the Add/Browse buttons to add the full path for that location.

  3. Click OK.

  4. Navigate to the workspaces in the status bar (wheel symbol) and select one of the available workspaces.


Customization (*.cuix) file is corrupted

  1. Look for a default copy of the *.cuix file within the path C:\program files\autodesk\autocad 20xx\userdatacache (search for *.cuix in that location and include subfolders).

  2. Copy the program's intended customization file (acad.cuix, acadlt.cuix, acade.cuix, etc.)

  3. Paste it into the user's Support folder, where the file typically resides.

Note: Alternately, there is a backup copy of the CUIx file within the user's Support folder, with a .BAK filename extension. Changing that extension to.CUIx will allow the program to use it.


Toolbars, palettes, or ribbon commands are not added to the workspace

  1. Enter CUI on the command line.

  2. Select the specific workspace.

  3. Click "Customize Workspace" at the top right.

  4. Switch to the specific missing toolbar, palette, or ribbon command on the left side and check a hook for each.

  5. Click the button "Done".

  6. Close Project Setup with "OK".


Reset Settings to Defaults:


Install AutoCAD updates

See: Install Updates, Add-ons, and Enhancements.


Update video driver

See: How to update to the latest certified video driver.

Note: If the graphics card is not certified and the latest driver does not fix the issue, the problem could be hardware-related. Consider installing a certified graphics card or consider running AutoCAD without hardware acceleration (See Starting AutoCAD-based products without hardware video acceleration).


Reinstall .NET Framework and Visual C++

Remove and reinstall the .NET Framework (or update to the latest version on Windows 10/11 systems) and Visual C++. Look for these articles: How to remove and reinstall the Microsoft .NET Framework and How to remove and reinstall Microsoft Visual C++ Runtime Libraries.


Sign in to the computer as the local administrator

High restrictions on user accounts can inhibit AutoCAD functionality (See Unable to run AutoCAD as a restricted user).


Repair or reinstall AutoCAD


Addition of 3rd party add-on - Uninstall 3rd party add-ons.

Note: Test again afterward to ensure that the add-on is the cause of the issue. Reload the third-party add-on and save the profile under a new name in the options.


Set up exclusions in the antivirus to allow AutoCAD to access its working files or folders

Antivirus can sometimes block AutoCAD from accessing its working files, for AutoCAD to run without issue, add exclusions to the antivirus program installed onto the computer (see:  How to set up antivirus (AV) exclusions to improve stability and performance of Autodesk software).

Note: A comprehensive list of known conflicting applications can be found here (see: Autodesk Licensing Service: Known Conflicting Applications).

Products:

AutoCAD for Mac; AutoCAD LT for Mac; AutoCAD Products;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support