“Install failed: The install couldn’t finish. Error 17” when installing or deploying Autodesk 2022 and newer version products due to AdSSO component

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

When installing or deploying Autodesk 2022 or newer version software, the installation may fail with error 17 related to AdSSO component installation.

For example, when installing or deploying Revit 2022 it fails with the following message:

Install Failed: Revit 2022

The install couldn't finish.
Error 17

Causes:

AdSSO component failed to install. Install.log in %localappdata%\Autodesk\ODIS shows:
2021-12-10T13:13:35.971 [Install Manager: 28420, single] [InstallManager INFO] [ InstallManager::HandleInstallFailure ] Package could not be installed (upi2: {8AE68CB2-6668-476B-A3CF-D591129AD697} Name: Autodesk Single Sign On Component )  Error code:  1602 Exit Status: 17 

 

Solution:

To resolve this error select the applicable option:

Option 1

  • Reboot the system and restart the installation.

Option 2

  • If the system reboot is not an option, or reboot didn't work you may install AdSSO from its MSI file found in the product installation media or the deployment image.
For example, installing AdSSO from Revit 2022 the deployment image.
  1. Navigate to your deployment image folder
For example for Revit 2022 deployment it would be...\<imagename>\image\RVT_2022_en-US\x64\AdSSO.
  1. Install the AdSSO.msi file manually or modify your script to install this prior to the deployment.
  2. Run the deployment/install again.

Products:

Revit; All Desktop Products;

Versions:

2022;


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