"There is a problem with this Windows installer package. A DLL required for this install to complete could not be run..." during installation of an Autodesk product

Autodesk Support

Oct 8, 2023


Products and versions covered


Issue:

During the installation of an Autodesk product, the following error message appears:
 
There is a problem with this Windows installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor.

User-added image

image.png
 
 

Causes:

  • Missing vital Windows updates that are necessary for the program to install.
  • Lack of permissions to the user's TEMP folder located in (C:\Users\<username>\AppData\Local\Temp)

Solution:

Make sure to do the following:
  • Install latest Windows updates, restart machine, re-launch installer.
  • Re-install the Visual C++ as shown in this article.
  • Re-download installer from Autodesk Account portal.
  • Assert 'Full-Control' permissions to the user's TEMP folder. This can be done by navigating the TEMP folder (listed below). Right-click the 'Temp' folder and select 'Properties'. Go into the 'Security' tab and choose the current user within the Group or user names and then click 'Edit'. At the bottom of the Windows, verify that 'Full Control' permissions as been checked off and save.
    • C:\Users\<username>\AppData\Local\Temp
    • %LOCALAPPDATA%/Temp

Products:

All Desktop Products;

Versions:

2017; 2016; 2019; 2020; 2018; 2021; 2022;


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