Fonts are not shown correctly on PDF and DWF files created from AutoCAD files by Vault Job Processor

Autodesk Support

Feb 5, 2025


Products and versions covered


Issue:

DWF and PDF preview files created using the Vault Job Processor show textual errors and substituted fonts:

  • Some fonts that are originally included in the CAD drawing are not shown correctly. 
  • Readability of AutoCAD DWG file's visualization is decreased.
  • Publishing the DWF manually from AutoCAD is correct

Causes:

Fonts are missing from the Vault Job Processor.

Solution:

For AutoCAD files with this issue, try to enable the option to 'Include Font Handling' in the Vault client which should embed the fonts within the PDF:
PDF Publish Include Font Handling

Follow these steps further if the issue is still there or it is affecting other CAD formats:
  1. Open the drawing in CAD and determine which fonts were used to create the text that appears incorrect on the PDF/DWF file.
  2. Copy the specific fonts from "C:\Windows\Fonts" from the local machine to the same folder on the Job Processor machine.
  3. In addition, copy the missing fonts to "C:\Program Files\Autodesk\Vault Professional [version]\Explorer\Fonts" on the Job Processor machine.
  4. Restart the Job Processor Client.
  5. Re-create the PDF/DWF file leveraging the Vault Job Processor.
 

Products:

AutoCAD Products; Inventor Products; Vault Professional; Vault Workgroup;


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