Wie installiere ich eine 64-Bit-Version der Microsoft Access-Datenbank-Engine neben einer 32-Bit-Version von Microsoft Office?

Autodesk Support

22. November 2024


Abgedeckte Produkte und Versionen


Problem:

  • Beim Installieren der Microsoft Access-Datenbank für die 64-Bit-Version wird eine Fehlermeldung ähnlich der folgenden angezeigt:


Installation von Microsoft Access Database Engine 2010 (Englisch)

Sie können die 64-Bit-Version von Microsoft Access Database Engine 2010 nicht installieren, da Sie derzeit 32-Bit-Produkte installiert haben. Wenn Sie die 64-Bit-Version von Microsoft Access Database Engine 2010 installieren möchten, müssen Sie zunächst die 32-Bit-Installation von Office-Produkten entfernen. Führen Sie nach der Deinstallation der folgenden Produkte das Installationsprogramm erneut aus, um die 64-Bit-Version von Microsoft Access Database Engine 2010 zu installieren:
Microsoft Office Professional Plus 2010

Installation von Microsoft Access Database Engine 2010 (Englisch) Sie können die 64-Bit-Version von Microsoft Access Database Engine 2010 nicht installieren, da Sie derzeit 32-Bit-Produkte installiert haben. Wenn Sie die 64-Bit-Version von Microsoft Access Database Engine 2010 installieren möchten, müssen Sie zunächst die 32-Bit-Installation von Office-Produkten entfernen. Führen Sie nach der Deinstallation der folgenden Produkte das Installationsprogramm erneut aus, um die 64-Bit-Version von Microsoft Access Database Engine 2010 zu installieren: Microsoft Office Professional Plus 2010

 
  • Wie installiere ich die 64-Bit-Version der Microsoft Access Database Engine auf einem Computer, auf dem eine 32-Bit-Version von Microsoft Office (2007, 2010 oder 2013) ausgeführt wird?

Anmerkung: Ein Beispiel gilt für Access Database 2010, für Version 2016 wird jedoch eine ähnliche Meldung angezeigt.

 

Ursachen:

Microsoft bietet keine Unterstützung für die parallele Installation von 32-Bit- und 64-Bit-Versionen von Microsoft Office oder deren abhängigen Komponenten.

Lösung:

VIDEO TUTORIAL


So installieren Sie die 64-Bit-Version der Access-Datenbank-Engine mit der 32-Bit-Version von Office:

  1. Öffnen Sie den Registrierungseditor (geben Sie regedit in das Windows-Suchfeld im Startmenü ein, und wählen Sie regedit.exe).
  2. Wechseln Sie zu den Registrierungsschlüsseln: 
    • For MS Database engine 2010: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Common\FilesPaths 
    • For MS Database engine 2016: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Common\FilesPaths 
  3. Überprüfen Sie, ob der Wert mso.dll vorhanden ist. Dieser Registrierungsschlüsselwert wäre vorhanden, wenn eine 64-Bit-Version von Microsoft Office auf dem Computer installiert ist. Wenn der Schlüssel nicht vorhanden ist, führen Sie die folgenden Schritte aus:
    • Öffnen Sie die Eingabeaufforderung, indem Sie cmd in das Windows-Suchfeld im Startmenü eingeben und cmd.exe
    • Geben Sie den Dateipfad und Dateinamen der 64-Bit-Installationsdatei von Access Database Engine 2010 oder 2016 ein, gefolgt von einem Leerzeichen und /quiet (dadurch wird die Installation ausgeführt, ohne Meldungen anzuzeigen). 
Beispiel:
AccessDatabaseEngine_x64.exe /quiet
Administrator: Eingabeaufforderung
  1. Öffnen Sie den Registrierungs-Editor, indem Sie regedit in das Windows-Suchfeld im Startmenü eingeben und regedit.exe
  2. Löschen Sie den mso.dll Registrierungswert im folgenden Registrierungsschlüssel, oder benennen Sie ihn um: 
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\14.0\Common\FilesPaths 
  • HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\16.0\Common\FilesPaths

Registrierungs- Editor

Anmerkung: 

  • Wenn der Registrierungswert "mso.dll" nicht gelöscht wird, wird beim Öffnen eines Office-Programms eine Meldung über die Neukonfiguration angezeigt.
  • Diese Alternative ist möglicherweise temporär, da Microsoft Updates für Office und die zugehörigen Komponenten mit Windows-Updates bereitstellt. Da 64-Bit-Autodesk-Software nicht mit Office-32-Bit-Komponenten kompatibel ist, bestünde eine dauerhafte Lösung darin, neben einer 64-Bit-Version von Office 64-Bit-Software zu installieren.
 

Produkte:

Alle Desktop-Produkte


Waren diese Informationen hilfreich?


Benötigen Sie Hilfe? Fragen Sie den Autodesk-Assistenten!

Der Assistent hilft Ihnen dabei, Antworten zu finden oder einen Mitarbeiter zu kontaktieren.


Welche Supportstufe haben Sie?

Verschiedene Abonnementverträge bieten unterschiedliche Supportkategorien. Finden Sie heraus, welche Supportstufe Ihr Vertrag unterstützt.

Supportstufen anzeigen