"A fatal error has occurred. The application will be terminated" while opening/working on a file in Revit

Autodesk Support

Dec 10, 2024


Products and versions covered


Issue:

While opening a Revit project or selecting elements in the project, a message appears:
 

Revit 

 

A fatal error has occurred. The application will be terminated. You have the opportunity to save recovery files for all of your changed projects.
 

Would you like to save a recovery file?


image of Fatal Error screen

 

Causes:

A Revit element that was recently modified in the project may be corrupted.

Solution:

You may be able to correct the problem by selecting the Audit option when opening the Revit project file and resave the file.

File Based Worksharing:

  1. Select "Open > Project" from the Revit menu.

  2. Check the Audit option (see below image)

  3. Select the name of the file that you are trying to open and click Open.

Revit File Open dialog displaying the Audit option.


Cloud Based Worksharing:

  1. Navigate to the file from the Autodesk Docs/BIM 360 section of the Revit Home screen.

  2. Click the three dots to display the menu of commands. (See image below)

  3. Select "Open and Audit".

Audit Cloud Workshared Revit file

For additional information about Audit, see Help | Audit a Model.

Other Troubleshooting:

If the previous information does not lead to a solution, see the following guide for other possible causes of this error: Guide: An unrecoverable/fatal error has occurred when using Revit

 

Products:

Revit Product Family;


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