"Problem installing Fusion. SSL: DECRYPTION_FAILED_OR_BAD_RECORD_MAC" when installing Fusion

Autodesk Support

Feb 25, 2025


Products and versions covered


Issue:

When installing Fusion the following error is displayed:

Problem installing Fusion

We are not sure what is preventing installation.

[SSL: DECRYPTION_FAILED_OR_BAD_RECORD_MA
C] decryption failed or bad record mac (_ssl.c:###
#)

ssl.SSLError: [SSL: DECRYPTION_FAILED_OR_BAD_RECORD_MAC] decryption failed or bad record mac (_ssl.c:####)

 

Causes:

Unstable internet connection being used to install Fusion 360.

Solution:

To solve the issue, try the following.

  • Use an ethernet cable instead of Wi-Fi to connect to the internet before installation.
  • Disable unnecessary background processes from Startup in Task Manager and then restart the computer.
  • perform a clean uninstall 

 

Products:

Fusion;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support