Installation hangs on "Preparing..." or "Preparing to install" while installing an Autodesk product

Autodesk Support

Feb 12, 2025


Products and versions covered


Issue:

Users reported that while trying to Install an Autodesk product using the New Installation Experience (see Does my product or update use the Autodesk New Installation Experience or the Classic Installer?) the install wizard hangs on "Preparing..." (single install) or "Preparing to install" (deployment).

Preparing installation box

Preparing to install installation box
 
 

Causes:

  • Operating System is not up to date.

  • Installer not able to start properly.

  • Unable to download updated Autodesk components due to restrictions.

  • Datto RMM may be preventing the installer from being created. There will be no notification in Datto logs.

Solution:

To solve the issue try one of the following:

Uninstall and Reinstall the ODIS component before installing the software

  1. Go to C:\Program Files\Autodesk\AdODIS\V1.

  2. Run RemoveODIS.exe as administrator.

  3. Backup and Remove the contents of folder C:\ProgramData\Autodesk\ODIS\

  4. Download and install latest version of ODIS.

  5. Run the product installer again.

 

Install the latest updates for your Operating System

  1. Type Windows Updates on the Windows Start button.

  2. Search for new updates and install them.

 

Install the latest update or download the latest version of the Autodesk product using the Direct download option

  1. Before extracting the Browser Download, right click the downloaded file and select "Properties".

  2. In the "General" tab in the "Security" section select the box for "Unblock" and apply the change: 

Selecting the Unblock box for the Security section under the General Tab after right clicking and selecting Properties for the download file
  1. Then run the extraction by clicking the first file, 001_00n.

  2. After the extraction is completed, proceed to the launching the Setup.exe.

 

Launch the Setup.exe using the switch --noupdate to enable the offline mode installation

  1. Go to Windows Start button.

  2. Type cmd to open Command prompt and run it as administrator. 

  3. Type the following and press ENTER. 

    cd C:\Autodesk\Autodesk_3ds_Max_2021_EFGJKPS_Win_64bit

Note. The path above can be different -according to the software you are trying to install- check first the exact path in C:\Autodesk.

  1. Type the following and press ENTER.

    Setup.exe --noupdate

CMD noupdate installation

Note. The image above is just an example with the AutoCAD 2022 installer.

 

    Datto RMM is blocking the installer from being created

    1. Uninstall Datto RMM via Control Pannel>Programs and Features or have IT uninstall this software.

    2. Launch the installer for Autodesk program.

    3. After software is installed you can reinstall Datto RMM and software should still opperate.

    Products:

    All Desktop Products;


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