"This operation could not be completed. Please try again" when opening a cloud model in Revit

Autodesk Support

Mar 13, 2025


Products and versions covered


Issue:

  • Users reported that the following message appears when trying to open a cloud model from BIM360/ ACC (Autodesk Construction Cloud) in Revit:

Open Model 

This operation could not be completed. Please try again.

Image of error message, "This operation could not be completed. Please try again."
  • The journal (Revit log) will show entries similar to the following:

' 4:< Time: #/##/#### ##:##:##:### Calling: IdentifyModel 
      ' 4:< Internal Server Error 
      ' 4:< Failed to refresh cached central file for C:\Users\%USERNAME%\AppData\Local\Autodesk\Revit\Autodesk Revit ####\CollaborationCache\{User GUID}\{Project GUID}\LinkedModels\{Linked Model GUID}.rvt 
      'C ##-###-#### ##:##:##.###;   4:< Invalid Communication Exception while interacting with Revit Server. Please contact technical support. 
      ' 4:< TaskDialog "This operation could not be completed. Please try again."
  • In some situations, the issue occurs only for specific team members, and the model works for others (It depends on the set of worksets opened during the model opening).

Causes:

One or more linked models have been deleted from the Cloud Service, leading to this error when Revit tries to resolve the link.

Solution:

Update Revit

Follow the article: How to keep Revit updated.

Identify the corrupted link

  • Find the link in the journal file:

    1. Locate the Revit journal in C:\Users\%username%\AppData\Local\Autodesk\Revit\Autodesk Revit ####\Journals
    2. Review the Revit journal for the name of the link (see the journal sample in the Issue section).
  • Alternatively, reload each link to find which one returns the error:

    1. Open the model with the worksets turned off.
    2. Reload each link to find the one causing the error.

Remove link

  1. Remove the previously identified links, or use the Reload From tool to load a replacement file.
  2. Turn worksets back on.
  3. Confirm that the error is cleared.

Recover the last working backup of the removed model

  1. Download the last working published model
  2. Initiate the model to the cloud

Note: Look at the following articles for more information about the file recovery:

More troubleshooting

Products:

Construction Cloud; BIM 360; Revit Cloud Worksharing; Revit Product Family;


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