Crash occurs on some Dell PCs when opening, saving, or browsing for a file in Autodesk products

Autodesk Support

Dec 16, 2024


Products and versions covered


Issue:

After installing Autodesk software, a crash occurs when trying to browse to a user-configurable path, such as the location of a previously saved file to open. This happens on certain Dell PCs (both desktops and laptops). Affected Autodesk software includes 3ds Max, AutoCAD, Civil 3D, ReCap, InfraWorks, Inventor, Revit, and others. A crash report dialog box may appear.

Instances of this crash behavior would be:
  • Using the File > Open menu.
  • Using the File > Save menu.
  • Using the File > Save As... menu.
  • Using the File > Import options.
  • Opening the Material Editor and browsing for a bitmap file.

Environment:

  • Dell workstations and laptops
  • Dell Backup and Recovery

Causes:

Dell Backup and Recovery system in Windows may cause conflicts with Autodesk products, particularly the following three (3) DLLs:
  • DBRShellExtension.dll
  • DBROverlayIconBackuped.dll
  • DBROverlayIconNotBackuped.dll

Solution:

To resolve the issue, try one of the following:

Update AutoCAD to the latest version

Update to the latest version of the product

Note: Updates can also be readily installed through the Autodesk Access. Click here to install he latest version.

If using Dell Backup and Recovery application: Update the application

If actively using Dell backup and Recovery system, update to the most recent version of the application.

As noted in a Dell forum thread, previous versions of the application did not use new Qt implementations and the recent versions of the application removed the dependency in the shell overlay DLLs. See the Dell forum thread on the topic here: Backup and Recovery causing applications using Qt5 DLLs to crash.


If not using the Dell Backup and Recovery application: Manually Rename the Dell Backup and Recovery DLL Associations

To resolve any crashes when navigating to and selecting files in Autodesk programs, rename the Dell Backup and Recovery DLLs by performing the following steps:

  1. In Windows, go to Windows Explorer.
  2. Browse to the location: C:\Program Files (x86)\Dell Backup and Recovery\Components\Shell.
  3. Manually edit the file name of each of the noted DLLs so that they cannot be loaded. (For example, adding a *.bak to the file name, such as "DBROverlayIconBackuped.dll.BAK" will prevent the file from loading).
DLLs files



Alternate Method to unregister the Dell Backup and Recovery DLL Associations 

If using the Command prompt is preferred to unregister the Dell Backup and Recovery system DLLs, use the steps described below: 

  1. Go to the Windows Start menu.
  2. Type Command prompt or CMD.
  3. Right-click on the Command prompt option shown and choose Run as administrator.
  4. At the Command prompt window, copy and paste the following lines one at a time, pressing "Enter" after each. ​A confirmation will appear after each entry is successful.
    regsvr32 /u “C:\Program Files (x86)\Dell Backup and Recovery\Components\Shell\DBRShellExtension.dll”
    regsvr32 /u “C:\Program Files (x86)\Dell Backup and Recovery\Components\Shell\DBROverlayIconBackuped.dll”
    regsvr32 /u “C:\Program Files (x86)\Dell Backup and Recovery\Components\Shell\DBROverlayIconNotBackuped.dll”

    Command Prompt 
     
  5. Restart the Autodesk program. The appropriate functionality to open, save, and browse for files should be available.


Important Note: Error when unregistering a DLL through the Command prompt:

Sometimes an error may occur when unregistering the DLLs through the Command prompt, as the DLLs may not reside in the default C:\Program Files (x86) folder.
 
Error message - RegSvr32

If Command prompt returns the above error and is unable to find the DLLs in the default paths above, try the following:
  1. Go to the Windows Start menu.
  2. Type Regedit.
  3. In the Windows Registry, navigate to the Edit menu.
  4. Choose Find.
  5. Type in the name one of the DLLs listed above. For example: DBROverlayIconBackuped.dll

    ​​Find window 
  6. Select Find Next.
  7. Once the DLL is found, the path to the file can be determined by checking the bottom status bar of the Registry.
  8. Select the newly located DLL.
  9. Right-click and choose Modify to copy the full file path listed there. 
  10. Replace this path in each of the three (3) previously noted commands.
For example: 
regsvr32 /u “[Copied Registry Path]\DBRShellExtension.dll”
  1. Repeat the first four steps of this section of the article to unregister the new file path locations for the DLLs.

Products:

All Desktop Products;


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