Large Assembly Management

Contents

Large Assembly Management ........................................................................................................ 1
Large Assembly Best Practices .................................................................................................... 3

What are large assemblies? ........................................................................................................... 4
Model based .................................................................................................................................. 4
Drawing based ............................................................................................................................... 4
Hardware based ........................................................................................................................... 4

Large assembly terms and considerations .................................................................................. 5
Occurrence ..................................................................................................................................... 5
Performance ................................................................................................................................. 5
Capacity ......................................................................................................................................... 5
Express mode ............................................................................................................................... 5

Common Practices that may Impact Large Assembly Performance ........................................... 5
Practice: Using more than one LOD representation in a drawing .................................................. 5
Practice: Overuse of Adaptivity ..................................................................................................... 5
Practice: Leaving Contact Solver running after using it ................................................................. 6
Practice: Other Factors ................................................................................................................ 6

About Project Planning and File Management ........................................................................... 7
Folder Structure ............................................................................................................................ 7
Planning for Assembly Hierarchy Efficiency ................................................................................ 7
Project Files and Libraries ............................................................................................................ 7
Use a Custom Content Center Library ......................................................................................... 8

Preferences and Settings ............................................................................................................. 9
Application options ..................................................................................................................... 9
Document Settings ..................................................................................................................... 14
Unload Unnecessary Add-ins ....................................................................................................... 15
Visualization Effects and Graphics .............................................................................................. 16

About Express Mode .................................................................................................................. 17
Use Assembly Selection Filters to Improve Performance ............................................................ 20
Large Assembly Modelling Workflows ....................................................................................... 20
Managing Component Count ...................................................................................................... 23
Representations ............................................................................................................................ 23
Simplify Components .................................................................................................................. 26

Additional Practices to Employ .................................................................................................... 27
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Assembly Joint and Constraint Relationships</td>
<td>27</td>
</tr>
<tr>
<td>Resolve Relationship errors</td>
<td>28</td>
</tr>
<tr>
<td>Model Error Handling</td>
<td>29</td>
</tr>
<tr>
<td>Drawings of Large Assemblies</td>
<td>30</td>
</tr>
<tr>
<td>System Hardware and Large Assemblies</td>
<td>31</td>
</tr>
<tr>
<td>Hardware and system recommendations</td>
<td>31</td>
</tr>
<tr>
<td>To Increase Capacity of System Memory</td>
<td>39</td>
</tr>
<tr>
<td>General</td>
<td>39</td>
</tr>
<tr>
<td>Parts</td>
<td>39</td>
</tr>
<tr>
<td>Assemblies</td>
<td>40</td>
</tr>
<tr>
<td>Drawings</td>
<td>41</td>
</tr>
<tr>
<td>Additional Information</td>
<td>41</td>
</tr>
<tr>
<td>Autodesk forum link on popular discussion on graphics card</td>
<td>41</td>
</tr>
</tbody>
</table>
Large Assembly Best Practices

Learn how to optimize performance, streamline your design techniques, plan your design approach, and solve issues that arise as your design progresses.

As product designs become larger and more complex, they consume more computing resources. Several tools and techniques are available to improve the following consequences of working with large data sets:

- Longer than expected load times.
- Out of memory errors.
- Poor graphics performance.
- Difficulty creating drawings.
What are large assemblies?

Inventor assemblies can be as large as 100,000 occurrences and 10,000 unique parts or more. An occurrence is a reference to a part or subassembly from the main assembly. A more typical large assembly probably contains 3,000 - 5,000 occurrences with 1,000 to 2,000 parts. There is no exact number that defines a "large" assembly.

A large assembly is any assembly file that adversely affects performance. Common reasons for performance impact include:

**Model based**
- Number of component occurrences
- Number of unique files
- Complexity of geometry
- Heavy data from supply chain sources and business partners
- Hardware configuration affecting

**Drawing based**
- Drawings referencing multiple LODs

**Hardware based**
- RAM
- Hard disk speed or capacity
- Processor speed or cores
- Video Cards
- Multiple hard disk Raid setup.

For details see: System Hardware and Large Assemblies (page 43)
Large assembly terms and considerations

Occurrence

A reference to a part or subassembly from the main assembly. An occurrence is a reference to a part or subassembly from the main assembly. Thus, if you pattern a bolt eight times, you would have eight occurrences and one unique part. In the model browser, component names are followed by a colon and occurrence number, as shown in this example:

- 3500_250_1750:1
- 3500_250_1750:2
- 3500_250_1750:3
- 3500_250_1750:4

Performance

The speed at which a task completes. The amount of time it takes to open a file, create a drawing view, or render an image is performance related.

Capacity

The amount of memory required to perform an operation. Capacity affects the number of components you can effectively use in an assembly, or show in a drawing view.

Express mode

Express mode is a method of working with very large assemblies and dramatically reducing the file open time. Express mode optimizes performance by loading only model display and relevant top-level data.

Common Practices that may Impact Large Assembly Performance

Learn about common practices that can impact large assembly performance.

Practice: Using more than one LOD representation in a drawing.

**Impact:** For each view using a different LOD, a copy of the assembly is loaded into memory. For a large assembly, this can increase memory usage drastically.

**Best Practice:** Use View Representations instead of LODs. If you must use an LOD, use the Master LOD for all drawing views.

Practice: Overuse of Adaptivity

**Impact:** It can lead to performance problems at the assembly level because the part geometry must be updated along with assembly constraints. All impacted parts are recomputed.

**Best Practice:** Use adaptivity discreetly. Adaptive relationships must a clear adaptor and adaptee defined to avoid cyclic relationships. Cascading adaptive relationships should be avoided, i.e. Part1 drives Part2 and Part2 drives Part3. Consider using Skeletal modeling instead. After using adaptivity, consider turning adaptivity off until model updates occur, then turn it on and allow it to resolve. Then, turn it off until the next change.
Practice: Leaving Contact Solver running after using it.

Impact: Doing so can affect performance. If not using it, turn it off.
Best Practice: Develop the habit of turning it off when finished performing a contact analysis.

Practice: Other Factors

Issue: An under-constrained subassembly. Components within the subassembly are constrained to subassembly origin planes, axes, or point.
Impact: The flexible subassembly exposes all the degrees of freedom within the subassembly. The subassembly origin planes can be moved and all components constrained to the origin planes will move. Their DOF at the top level assembly becomes confusing.
Best Practice: Ground the flexible subassembly. If components within the subassembly have DOF and they are supposed to be free, avoid creating constraints to subassembly origin planes, axes, or point.

Issue: Top-level assembly is left at the older version while some of its components are saved in newer versions. Opening the top-level assembly in older version of Inventor and keep working on it can lead to corruption.

Issue: Low system memory (machines with <16GB)
Impact: Depending on geometric complexity and assembly levels, Inventor may require more memory than the minimum 8GB. For a typical 10K component assembly, it takes about 3GB to fully load the assembly. If there are other processes running at the same time, Windows use swap (hard drive) memory. When it happens, it will slow down Inventor operation.
Solution: Increase system memory to avoid hard drive memory swapping.

Issue: Use derived parts in drawing views.
Impact: To reduce complexity some have resorted to using derive on large assemblies before creating views. When a derived component is used in a detail view, the entire model is calculated for creating the view instead of just the participating components. This has a negative performance impact.
Best Practice: Avoid the practice of using Derived or Shrinkwrap models with Detail drawing views.

Issue: Using complex sketch patterns for extruded features, such as cutouts.
Impact: Modelling features like threads, patterned cutouts, etc. can impact performance, particularly when editing the component or using patterns of these components in assemblies. For example, think of a wire fence component which was created using cutouts and, then, is patterned as a component in the assembly.
Best Practice: Use Appearances (textures) to represent the cutouts. You can still see through the gaps without having to model the cuts. You can apply an iproperty override to provide the correct mass properties for CoG investigations, etc.
About Project Planning and File Management

Learn about project planning, folder structures, project files and libraries as they relate to large assembly modeling.

Folder Structure

A flat folder structure, all documents in the same folder and also referred to as "narrow and deep," can be the easiest for software to engage with. This folder structure is impractical when working with hundreds, even thousands of parts. At the same time, the "width" of the folder structure, the number of subfolders and subfolders within subfolders, should be kept to a reasonable minimum.

Planning for Assembly Hierarchy Efficiency

Create a shared network directory for components that can be used by designers on many projects. Assign the Summary and Project properties for individual components. Create a unique template and use it to create components for a specific project or subassembly. Predefine common properties in the template so all components created from that template inherit the properties. Search for attributes both inside and outside Autodesk Inventor to find needed component files. Save and name attribute searches that you are likely to use again.

Project Files and Libraries

Project files organize Inventor data, and determine the location of the working data, templates, styles, and libraries. The following are suggestions for improving performance:

- Set the Included File path option to point to a single, read-only project file maintained on the network by the CAD administrator.

- Never locate a Workspace on a network location. It is intended to be on local machines. Perform all work on files held locally and copied back to the network when finished.

- Never define Workgroup or Library locations that point to subfolders of the Workspace or another Workgroup or Library. For Example: Workspace - C:\Damper

- Workgroup - C:\Damper\Section1

If the Workgroup or Library location is a subfolder of another defined location, Inventor highlights the offending path in red. You can still save the project file. It is a warning that the location does not produce the most efficient file structure.

- Mapped network drives will slow down the machines ability to open and save files as Windows attempts to resolve these every time.

- Keep relative paths = true. Relative in this instance means relative to the location of the project file.
- The fewer workgroup search paths defined, the better. Fewer search paths improve searches for files. Make your assembly structure flat. For example, if you have an assembly file in a folder, place all .idw files of that .iam in the same folder. In a subfolder, place all the components in the iam. Inventor uses the Subfolder Path to locate the components it needs. This improves file search efficiency.
- If your projects require portability, define all storage locations as subfolders of a project folder. The project folder contains only the project file (*.ipj).

Use a Custom Content Center Library

Inventor Content Center database contains over 750,000 parts and covers 18 international standards. Considering your design requirement, only loading necessary library will boost your speed to load Content Center and place from it.
If you only use small portion of library content, consider copying your required families to the custom library, then only load it in your project setting.
Preferences and Settings
Learn which settings can be optimized for large assembly performance.

Application options
The following are Application Options that affect assembly performance.

General tab
- Show command prompting - OFF
- Enable Optimized Selection - ON
- Undo File Size - 8191 MB is the maximum undo file size
File tab
- Design View Representations > Associative = Checked
- Design View Representations > Last Active

Colors tab
- Enable Pre highlight - off

Display tab
- View transition time - 0
- Minimum frame rate - 10
- Display Quality - Rough
- Disable Automatic Refinement - on
- Show Origin 3D Indicator - off
- Show Origin XYZ axis labels – off

Hardware tab Performance - on Drawing tab
- Retrieve all model dimensions on view placement - unchecked
- Display line weights - unchecked
- Show preview as - Bounding Box
- Section View Placement as Uncut - checked, the section preview is not used and the view window quickly previews the uncut model.
- Enable background updates - checked, this option displays a representation of the view before it is calculated. You can continue working in the drawing, and dimension the view, while the view calculates.

**Notebook tab**

Note icons - off Sketch tab Autoproject edges for sketch creation and edit – unchecked
Assembly tab

- Defer Update - checked
- Enable Constraint Redundancy Analysis - unchecked
- Enable Express mode workflows = checked
- Open Express when referenced unique files exceed = selected
- Unique files = 500 (default), set to a value that works well for your purposes.
Defer on Open

Large Assembly Drawings can take time to open as all components or parts are checked for updates. You can defer the update process when opening a drawing by selecting Defer in the Open dialog box.

Document Settings

You can also set an open drawing to a deferred state. In the ribbon, click the Tools tab and in the Options panel click Document Settings. In the dialog box, click the Drawing tab and check the box next to Defer Updates. Views will not be updated with model changes until this setting is turned off or overridden when opening the drawing.

Active Document

If you are working in a drawing and want to turn on Defer Updates, right-click the top level drawing node in the browser and click Defer updates.

Document Templates

For drawing templates, specify the use of bitmaps for shaded views rather than 'Offline Only' during viewing operations. You can do so by opening the Standard.idw drawing template and Save As "Large Assembly Standard.idw." In the Tools tab > Options panel click Document Settings. On the Drawing tab, in the Shaded Views section, set Use Bitmap to Always. Save the changes.
When inserting images into a title block, make sure the file is saved in the smallest size possible. This may mean using an image editor to reduce the color bit depth. An 8-bit png image uses 256 colors, but the same image as 32-bit png image uses 16,777,216 colors. If possible, reduce the file to 16 color or monochrome.

**Unload Unnecessary Add-ins**

To manage the add-in load behavior, go to the Add-in Manager go to All Programs ➤ Autodesk ➤ Autodesk Inventor #### ➤ Tools. Use the Add-In Manager to specify which add-ins load at startup. The available add-ins and their load behavior is listed in the dialog box. Add-ins not loaded at startup are listed without a load behavior. When an add-in is unloaded, its functionality is not available.

You can also unload some add-ins while in an Inventor session. Go to the Tools tab ➤ Options panel and click Add-ins, then change the settings for the in-session add-ins. Those that can be unloaded will be accessible, those unable to be unloaded will not be enabled.

There is an exception. All translator add-ins (such as DXF, DWF, and DWG) automatically load when that format is selected when doing a Save Copy As. By default, the translators are not loaded at startup. You cannot unload or load an Autodesk Inventor Professional add-in during an Inventor session. Restart the application for your selection to take effect.

Unloading unused add-ins can help to:

- Reduce the time it takes Autodesk Inventor or Autodesk Inventor Professional to load initially.
- Reduce the memory footprint for the application and increase the capacity enabling you to work with larger assemblies.

**TIP** If you experience capacity issues while using Autodesk Inventor Professional, unload some of the larger add-ins (such as Tube & Pipe, Cable & Harness) if they are not used in your design. In most cases, it is recommended that you do not unload Autodesk add-ins.

- Correct problems with the application. If you experience problems with Autodesk Inventor, start to unload non-Autodesk add-ins systematically to see if unloading corrects the problems. It is possible for some non-Autodesk Inventor add-ins to be invalid for a current release, and unloading them may correct problems.
Visualization Effects and Graphics

Inventor offers simple, easy to use visualization effects to enable realistic looking models in the viewport.

The effects available depend on the capabilities of your graphics hardware, operating system, and the Inventor graphics hardware setting in the Application Options ➤ Hardware tab.

The following illustrates the visual effects that you can experience from the Inventor graphics system, and the table below shows the specific settings in use.

You can query your system to learn more about the graphics capability:
With Inventor running, go to Tools ➤ Options ➤ Application Options ➤ Hardware tab and click Diagnostics. A dialog will display graphics hardware information when either the "Performance" or "Quality" option is active.
About Express Mode

Typically, an assembly opens fully (Load Full), that is, all component data is loaded into memory. For large assemblies, Inventor provides an Express mode (Load Express) where the model opens much faster by loading only component cached graphics into memory.

Express mode is an option that must be enabled. Once enabled, you have two open options. Load Full which loads all component data and enables all commands. For large assemblies, this can have an effect on performance and timing. Or, Load Express which loads only cached graphics and excludes some commands.

Load Express provides significantly faster (3-5x) file open times for large assemblies. Express mode causes enhanced display data (cached graphics) to be saved in an assembly (.iam) file. This extra data, referred to as Express data, is what enables Inventor to open the assembly faster.

As components are accessed to have tasks performed on them, they are loaded into memory. Those components are not unloaded from memory, so the performance advantage of Express mode gradually diminishes as you continue loading components. You can save the assembly and reopen it in Express mode to recover the advantage of working in Express mode.

**IMPORTANT** If you save a large assembly in Express mode and then insert that assembly in a new assembly, Express mode is not automatically enabled in the new assembly.

To get the maximum performance benefit from Express mode when you create new assemblies, enable Express mode **before** inserting sub-assemblies containing saved Express data.

**Enable Express mode**

To enable Express mode and set the default open behaviour in Application Options.
1  On the ribbon, click Tools tab ➤ Options panel ➤ Application Options

2  Click the Assembly tab.
3  Click Enable Express mode workflows.
4  Specify the File Open Option you wish to use. For working with large assemblies select **Open Express when referenced unique files exceed** and specify the value. This value sets the default open behaviour based on the unique file threshold value. This allows you to open very large assemblies in Express mode, while smaller or less complex assemblies fully open. File open times are based on factors such as number of occurrences, complexity of model geometry, and system hardware specifications.

**TIP** To revert the assembly file back to the original size, close all documents and then clear the **Enable Express mode workflows** check box. The next time you open and save the assembly file, the express data is removed.

**Saving Express data in assemblies**

To add Express data to an assembly do the following:

1  Ensure that **Enable Express mode workflows** is checked.
2  **Open** and **Save** an assembly. Express data is added to the assembly regardless of the number of files the assembly uses. This ensures assemblies respond to changes in the **unique files** value.

**NOTE** You can open any assembly that does not have **Express data** and use the **Load Express** option to save the assembly with **Express data** and reopen it in Express mode.

**Enter Express mode**

After you enable Express mode and save an assembly, the threshold value is used to invoke **Load Express** when opening an assembly that exceeds the unique files value. When opening an assembly you can override the default File Open behaviour using one of the following techniques:

- **Select Full or Express** in the drop-down list.
Use File Open Options

You can also use the File Open Options to specify opening the assembly in Full or Express mode. Access to File Open Options is available in the Home window.

![File Open Options dialog box](image1)

or the Open dialog box.

![Open dialog box](image2)

**NOTE** If the drop down list is not enabled, the assembly has not been saved with the necessary display data and will fully open. Refer to *Saving Express data in Assemblies* above.

**Express mode commands**

Some commands are not available in Express. If a required command is not available, click **Load Full** in the Productivity panel to gain access to the command. Available commands include, but are not limited to:

- Place Components
- Add Constraints or Joints
- Create Component
- Edit Component in Place
- Use Section View
- Create/Edit Work Features
- Pattern a component
Copy/Mirror component

Assemble

Representations

**Express mode and Drawings**

If you are working in a drawing, placing **precise views** of an assembly that is open in Express mode, the assembly will load whatever components are required to create the view.

**Use Assembly Selection Filters to Improve Performance**

There are some tips for using the Assembly Selection Filters to improve performance in large assemblies and to control what is being loaded into memory:

- Activate the Visible Filter to restrict the tools to only select from visible components.
- Set the selection priority to the appropriate object type to include in the selection set. It is generally useful to set the selection priority to Part priority to ensure all components are considered when creating a selection set.
- Use Visibility to turn off the visibility of groups of components. It speeds up subsequent loading of assemblies or drawing view creation. Upon achieving the appropriate result, create a design view representation to allow fast access to the same results in the future.
- Use the Assembly Selection Filters to create design view representations for drawing files. For example, when you place a view using a design view that was captured by the All in Camera tool, only objects in the Camera's view plane are computed, thus increasing performance and increasing capacity. This applies to design views created when working with any of the Component Selection commands.

**Large Assembly Modelling Workflows**

The various techniques and approaches that are available to model parts and create assemblies can affect performance. Your modelling approach determines the number of occurrences, complexity of geometry, constraint methods, and assembly creation.

It is common to mix techniques to fit your products and design intent. For example, you can use top down modelling to design and build a frame, and then use bottom up modelling to place and constrain components from a library. The following diagrams and brief descriptions provide modelling concepts leaving room for you to experiment with variations of the concept to realize the greatest benefit for your needs.

**Top-down, Bottom-up, and Middle-out Methods.**

**Top-down**

Top Down is a method where you start defining the end result and build in all of the known design criteria. This becomes the base for underlying sub-assemblies and parts. In this way you will have a
single conceptual file containing the overall information of the design with a single place for incorporating design changes.

Skeletal, top down design is a method of working with large assemblies. The benefits of using a skeletal technique include:

■ A much more stable Inventor model
■ Faster updates
■ More available resources for handling larger data sets
■ An easier way of working in a collaborative environment

**Skeletal Design Methods**

No single method suits every design process. You refine your use of the tools to develop efficient processes for producing their designs. Skeletal modeling is an example of that refinement process. Using the tools, customers, like you, have developed approaches to skeletal design that fit their needs. The following methods represent the best practices for using skeletal design methods.

**Skeletal Modeling: Single-Part**

The Single-Level Process uses a single master part containing sketches and geometry that represents the final design. The Master part is placed in the top-level assembly. All components (parts and subassemblies) are created relative to the Master part. Downstream, modifications to the Master part drive changes in the components associated to the Master part.

**Skeletal Modeling: Multi-Part**
The Multi-Level Process uses individual master parts comprised of sketches to represent the final assembly. The master parts are placed and constrained in a Master sub-assembly. The Master sub-assembly is placed in the Top-level assembly. Inside the Top-level assembly, the individual 3D components are modeled using projected geometry from the Master sub-assembly and its master parts. The 3D components can be contained in logical sub- assemblies or separate, according to the design requirements.

Skeletal Modeling: Distributed Master

The Distributed Master uses a single master part, comprised of sketches and geometry, to define the final assembly. The Master Part is referenced in the various sub-assemblies and parts as needed. The Master Part controls the overall layout. The assembly and sub-assemblies are defined or placed with respect to the Master Part. Each sub-assembly has its own skeleton and drive a portion of the design within itself. Higher level skeletons are used to drive the overall layout or mechanism of the assembly while lower level skeletons can be used to drive the geometry of the parts.

Bottom-up

Bottom Up is the traditional way of building assemblies. First, you define the different parts. Then, you put them into sub-assemblies using assembly constraints. The sub-assemblies are then placed into higher level assemblies up to the top level assembly and in this way, you are working your way from the bottom up. This assembly method results in assemblies with a number of relationships between parts and assemblies.

This approach can lead to two things:

1. It can consume system resources and slow down performance.
2. Model changes ripple through the design due to a lot of cross references and/or referenced geometry that are affected.

This diagram is provided as a comparison to the skeletal modeling methods mentioned above.
Middle-out
The Middle out combines aspects of both top-down and bottom-up methods. Some components exist, others are modeled separately or in-context. Cross-part references may be used to drive aspects of the design.

Linking Part Model Parameters
If you share parameters between parts, do not link them by an Excel spreadsheet. When the Excel file changes the software does not distinguish which files are affected, so an update is required for all parts. The performance of large assemblies slows down.

If you use global parameters, those used across designs, establish these parameters in your master parts and then link them one by one from the Parameters dialog box. This is the 'lightest' reference. Alternatively, use the Derive command in connection with the master part and select the parameters to use in the derived part. The software detects and updates only those files that a change affected.

Managing Component Count
For purchased or standard components consider not placing hardware parts at all, or only place one instead of many. Quantity overrides can be performed on the Bill of Materials and Parts List to accurately capture the required number of fasteners and other hardware in a design. If you need component presence, use component patterns to reduce component count.

You can reduce the number of visible components with the use of Representations.

Representations
Inventor has three types of representations: View, Position, and Level of Detail (or LOD). Two of these, View and LOD, can be leveraged to help with large assembly performance.

View Representation
View representations (view reps) store a component's current state when the view is created, edited, and then, saved. The saved view representation preserves component visibility, transparency, sketch visibility, work feature visibility, selection status, and camera state, magnification, viewing angle and
part view representations. View Representations load a component only once. Changing between view representations does not unload or reload components.

Use view representations to control the number components visible at a given time. View representations improve both assembly performance and capacity. Add standard view representations to your templates and configure these for each assembly.

To create view representations:

1. In the Assembly model browser, expand **Representations** and right-click **View** and in the context menu, select **New**.

2. Next, hide or modify components or scene aspects.

   **TIP** Use the tools in the **QAT** (Quick Access Toolbar), or in the graphics area, hold "Shift" and right-click to bring up the Selection Filters. To easily select all occurrences of the same component (**Select All Occurrences**) or all internal parts (**Select Internal Components**), make use of the appropriate selection option.

3. When the content of a view representation matches your intent, **Save** the document to preserve the representation. If you do not save it, the states will not be preserved.

Create as many view reps as you require to work efficiently. As you change between view representations the scene updates. Whenever a component is made visible, it is loaded into memory. Thus, if you have several view representations and activate each of them, all components made visible across the activated representations are loaded.

**TIP** To unload unnecessary components, close the document and reopen it with a specific view representation.
NOTE If you have existing models that have LODs, you can quickly create a matching view rep from the LOD. Open a model with the desired LOD active. Right-click the LOD and click Copy to View Rep. A view rep matching the LOD populates the browser.

Level of Detail Representation

A Level of Detail representation (LOD), is a view where non-essential components are suppressed. An LOD does not load suppressed components into memory. You can create multiple LODs.

LODs are not new to Inventor. They were designed to help manage memory limitations inherent to 32-bit computer architecture. At the time they were the best option for working with large assembly models. That, simply, is no longer the case due to 64-bit architecture and that support for 32-bit architecture ceased with the Inventor 2016 release.

When would you not want to use LODs?

- When changing between LOD’s the loaded components are unloaded and the next LODs components are loaded. The unload/load process is not always fast.
- LODs are used to create shrinkwrap substitutes of large assemblies. Shrinkwrap substitute files can be large which can affect performance. More simplification workflow information follows.
- If multiple LODs are used in a drawing, performance can suffer.

When should you consider using LODs?

- When you are working with reduced memory.
- When removing IP (intellectual property) from a model that is to be shared.
- When creating a configured family of parts where components are suppressed based on the configuration.

To create level of detail representations:

1. In a complex assembly, expand the Representations browser node. Right-click the Level of Detail node and click New Level of Detail.
   
   **NOTE** You can also use an LOD Shrinkwrap Substitute, these are discussed in the Simplification Workflows section.

2. Suppress all non-essential components or components completely hidden from sight. For example, showing every fastener may not be critical for certain drawings or design objectives. These can be suppressed. Use the selection filters and tools to expedite the process.

3. Save the Assembly file to preserve the representation.

**NOTE** You can easily create an LOD from a view rep. Open a model with the view rep active. Right-click the view rep and click Copy to Level of Detail. An LOD composed of the view representation visible parts populates the browser.
**Simplify Components**

After reducing component counts, the next thing to do is simplify the model. Simplification is a key step in reducing the number and complexity of components in large assemblies. Purchased parts and company standard parts should be modelled as simply as possible as these are often widely used parts that are modelled once and seldom revised.

Use the Shrinkwrap and Simplification tools to simplify your model. Each set of tools provides a different approach to simplification while yielding a simple part that can represent a more complex component.

**Shrinkwrap and Shrinkwrap Substitutes**

The Shrinkwrap command provides tools to remove components, features to remove or preserve, and finer details. With these tools, you can quickly get to a simplified model of the design. Shrinkwrap supports the use of view and LOD representations as input to the result. Shrinkwrap files can be directly referenced, as an alternative to the parent assembly, for drawings, distribution to partners, and so on.

To create a shrinkwrap part:

1. **Open** an Inventor Assembly.
2. On the **Assemble tab**, in the **Simplification panel**, click **Shrinkwrap**.
   
   **NOTE** At any time in the shrinkwrap process you can preview the result by clicking the Preview button in the dialog box.
3. In the **Shrinkwrap** dialog box, on the **Component tab**
   
   1. Specify the representations to use
   2. Use **Remove parts by size**. You can select a part and use the bounding box diagonal as input for the size value.
   3. Use View **Include** or **Exclude** to view and select components.
4. On the **Features tab**, further simplify the components by eliminating non-essential details such as small holes, pockets, fillets, and chamfers.
   
   1. Specify the feature size or select a feature to use its size.
   2. Click **Detect Features** to highlight features that will be removed. Select additional features as needed.
   3. To preserve features, regardless of their size, click the **Preserve Features** selection button and select the features to keep.
5. On the **Create tab**, specify the **Part Name**, template to use, file location, style and other settings.
6. Click **OK**. The part is created and opened in a new window, but has not had an initial save. Make any further refinements and **Save** the part.

**NOTE** Shrinkwrap file size can be much larger than its base model. The benefit is that it is a simplified, single part.
**Shrinkwrap Substitutes** uses a similar workflow to create a Shrinkwrap model, and then associates that result with the source assembly as an LOD, a lightweight representation or substitute for the parent assembly.

**Simplification Tools**

Simplification tools help reduce complex components to simple shapes that you create using either rectangles or cylinders. The Simplification tools are accessed by clicking the down arrow in the ribbon Simplification panel.

With these tools, you can:
- Create and edit a simplified view representation
- Define rectangular and cylindrical envelopes to substitute for complex components
- Create a simplified part from the representation

**Additional Practices to Employ**

**Assembly Joint and Constraint Relationships**

Fully constrain components or ground components that are not designed to move in your assembly. Assembly constraints require the software to perform a calculation. When there are many components in an assembly and each component has multiple assembly constraints, these calculation times can become significant.
Avoid redundant constraints. For assistance in locating these, use the Application Options ➤ Assembly tab ➤ Enable constraint redundancy analysis. Remove redundant constraints, then turn off the option.

- Use a common constraint reference if possible.
- Constrain symmetrical assemblies to the mid-planes or center axis.
- Resolve relationship errors as they occur.

**Resolve Relationship errors**

It is a good practice to resolve all relationship errors as they occur. However, attempting to resolve all constraint errors through in-place editing, starting at the top level, is an inefficient use of time.

When resolve errors occur a red cross displays in the Quick Access Toolbar (QAT). Clicking that button launches the Design Doctor which reports the errors. In the dialog box, select an error to highlight where the error occurs.

The most efficient way to resolve relationship errors is to:

1. Open EACH subassembly individually.
2. Resolve the relationship problem in the subassembly and save it.
3. Open the main or top level assembly, confirm relationship is resolved.
4. Repeat these steps as needed.
Model Error Handling

When model features produce errors, these need to be resolved before releasing your designs. Inventor provides Design Doctor (assemblies) and Sketch Doctor (parts) tools to help identify and resolve errors. In particular, missing references and constraint failures are key warnings, and affect Inventor performance. While you can work with missing parts and failed constraints, it is not good practice to do so for extended periods of time. Inventor finds that something is sick, performs an audit, and updates it every time you switch back to that file. If all errors are removed, assemblies behave more predictably and performance improves.

Work Geometry

Turn off the visibility of unnecessary work features - planes, axes, and points. Use the Object Visibility options to manage visibility.

1. After opening the model, in the View tab, in the Visibility panel, click Object Visibility.
2. Uncheck All Work features.
3. Uncheck other non-essential but visible items, such as weldment symbols if they are not needed in the view.

Turn Off Adaptivity

Adaptivity is a powerful tool for designing parts. Adaptivity should be turned off whenever it is not actively needed because adaptive components are frequently checked for re-computation which in turn affects performance. For assemblies use the Flexible option to exercise the degree of freedom.

1. Locate the adaptive part in the assembly browser.
2. Right-click the browser node and select Adaptive to remove the checkmark.

Parts

For standard parts that do not change, consider placing them in a project library folder. Inventor searches these parts in a different way than normal parts.

NOTE Do not change the name of an existing library folder. A change in the name requires that you resolve each part in the library.

Limit the complexity of purchased or library components to what is needed for accurate design (such as space envelopes, hole sizes, and locations). Adding unnecessary detail (such as textures, threads, coil features, fillets) can affect performance and capacity.

Suppress large feature patterns. Consider using a bitmap texture in place of large feature patterns.

Reduce part complexity. For example, do not model physical threads, fillets, and gear teeth if the detail is not required for manufacturing. Use the Simplification tools to remove complexity.
Engineer's Notebook

The Engineer's Notebook is useful for communicating design intent. When you create a note that contains an image, a bitmap embeds into the .ipt or .iam file and increases the file size. The larger the file size, the more hardware resources are used. Therefore, restrict the use of notes with images to minimize file size.

The Engineer's Notebook is in its own memory segment and loads only if notes are present. With no notes, the segment does not load, requiring fewer resources.

Drawings of Large Assemblies

The following can help manage drawing performance:

- Enabling background updates of drawing views displays raster drawing views for large assemblies and calculates precise drawing views at the background as you work. You can review the drawing or create drawing annotations before calculating drawing views finishes. See Preferences and Settings (page 10) for all large assembly related Application Options settings.

- Using design view representations. Components rendered invisible in the design view do not load into memory. Specify a simplified design view and level of detail representation before opening the model file.

1. Close the assembly file used for a drawing view to prevent its graphics from being loaded into memory.

2. On the ribbon, click **Place Views tab ➤ Create panel ➤ Base.**
   
   Click Open an Existing File
3 In the File Open dialog box, click Options and then select a design view and level of detail representation in the File Open Options dialog, and click OK.

4 Click Open to return to the Drawing View dialog box.

5 Specify the drawing view properties, and if appropriate, place projected views.

6 Click OK to close the Drawing view dialog box.

- Using Level of Detail representations. When creating a drawing of a top-level assembly, this suppresses unneeded components or replaces many parts with a single part representation. As a result, Inventor does not include them when computing the drawing view. Remember to use only one LOD per drawing to avoid introducing performance impact.

- Before starting the Base View command, clicking the Document Tab of the respective model to activate the appropriate document. This avoids calculating the base view preview for a different model. You can also close the last active model document, and select the source document manually.

- Selecting the Suppress option for several drawing views.

- Avoid or reduce the use of property overrides at the edge level. Use feature, body, or component level overrides instead whenever possible.

- Purge unused drawing styles.

- Keep drawing file size as small as possible by:
  - Limiting the number of views on a sheet.
  - Limiting the number of sheets in the drawing.

System Hardware and Large Assemblies

Learn about the influence of system hardware, operating system, and network on large assembly performance.

The information on this page is intended to help with performance and/or capacity. There is no single solution that helps in all situations. Use the solutions that help in your design environment.

Hardware and system recommendations

There are three ways to access your system information:

Computer Properties

Right-click My Computer ➤ click Properties, then view the basic information of the system, and you can click Device Manager to find more information there, eg. Click Display adapters to query the graphics cards and drivers information.
DirectX Diagnostics Tool

Query from system's DirectX Diagnostic Tool, which can be launched from Windows Start, typing dxdiag in the Search box, and then pressing ENTER, system information and graphics cards information can be browsed from System and Display tabs of the tool.

DirectX Inventor Diagnostics

Launch Inventor, open a document, then go to Tools ➤ Application Options ➤ Hardware. Click Diagnostics and Ok button, then you can paste the Inventor Diagnostics information to a text or word file, and watch these system and graphics information there.

General

These links will get you to the most recent information about System Requirements for various Inventor releases. ■ System Requirements

■ Autodesk certified graphics hardware

■ Certification team

Actual requirements vary depending on complexity of part geometry and number of occurrences.

Motherboards

To simplify searching for updates drivers/BIOS/Chipset Utilities, choose a motherboard that uses a chipset made by the same manufacturer. When selecting a CPU, consider the on board memory cache. The amount and type of on board cache can significantly affect performance.

Use a motherboard that uses a chipset of Intel or AMD. The chipset utilities of some other manufacturers can possibly present stability problems due to their implementation of the AGP interface. In this situation, you can uninstall them and rely on the generic windows drivers, which can adversely affect performance. Open a dialogue with the manufacturer to resolve this situation.

Even new machines rarely have the latest available BIOS from the manufacturer website. Download and update it.

Graphic cards

It is recommended that you use a DirectX11 graphics card with at least 2GB of video RAM.

Some Inventor users prefer a workstation level graphics card such as the NVIDIA Quadro family cards, AMD FirePro family cards, etc., which perform better than consumer level cards. It is a good practice to keep your graphics drivers and BIOS updated. If you use Nvidia or AMD, these are their driver support pages:


■ http://support.amd.com/us/gpudownload/Pages/index.aspx

If you are using laptop with a mobile graphics card, you can get the graphics drivers from the laptop vendor drivers download center.
**RAM**

The more RAM you have installed in your machine, the better. Check the motherboard spec to see the maximum amount of RAM that can be installed. Use the fastest RAM available.

We recommend at least 24 GB RAM for a large assembly with more than 1000 unique parts; if the number of unique parts is about 7000, the recommended RAM is 64 GB. Actual requirements vary depending on complexity of part geometry and number of occurrences.

Choose RAM that transfers data at the same frequency as the processor. For example, PC1066 RAM delivers data at 2,132 MB/sec which is the same as Intel 850E. Pairs deliver 4.2Gbytes/sec. A P4 CPU @ 533 MHz also works at 4.2GBytes/sec.

Use the Windows Task Manager to obtain detailed information on how your system RAM is being used.

**Hard disk drive configuration**

Hard drive read/write times affect the time required to open or save an assembly. **Solid-state drives** can significantly improve performance for large assemblies by reducing the time required to open or save an assembly. If you have enough budget, use an SSD drive. If budget isn't available, refer to the recommended hardware information.

**Organizing HDDs:**

For the purposes of this section, we can state that information stored on a computer hard disk can fall into one of the following four categories. Each category has a different requirement:

- **OS = Operating System**
- **Application = Inventor application**
- **Data = Inventor data files (ipt, iam, idw files, and the Workspace)**
- **Temp = Page file, undo and temp files**

In the most basic scenario, these items are on one or two partitions of the one physical disk in the system. In an ideal situation, they are on multiple volumes, where Temp is striped and Data is striped with fault tolerance.

There are a couple of reasons to separate these files:

**Data Access**

Files located in OS and Applications are accessed frequently (when a program is started the files are loaded once into memory). Files located in Data and Temp are read and written often while you work with Inventor. So, the greatest benefit comes from increasing the read and write access speed to Data and Temp by using faster hard drives.

**Fragmentation**

This is closely linked to Data Access. As files are heavily used, they fragment faster.

Separating the OS and applications is cosmetic, and does not result in much difference in performance.
Putting the Temp files on a separate partition ensures that they do not cause fragmentation of other files. To eliminate fragmentation easily, delete all files in the system Temp folder after closing all applications. Set the minimum page file size to the same value as the maximum page file size to increase performance when paging to disk. The page file does not fragment or cause fragmentation of other files. Also, as the page file is already set to the maximum size, no time is wasted expanding it. Create the page file first on the empty partition. Then it does not fragment, and there is no need to delete and recreate it.

Inventor uses segment loading when accessing files, which means that only the required parts of the file are loaded in memory. The rest remains on the hard drive. Therefore, when more segments from the file are required, it is beneficial if they can be read as fast as possible.

Follow these suggestions to improve performance:

- Ensure the OS\Applications & Data\Temp reside on different physical disks, at the least different partitions.
- Consider that the biggest performance gain is obtained in improving the speed with which Data and Temp are accessed. If you have multiple disks available, you can use software RAID (Redundant Array of Inexpensive Disks), striped volumes, to increase the performance. (Combine two disks into a striped volume and put your Data files on it.) Do the same for Temp. To attain even better performance and fault tolerance, consider the use of a hardware RAID solution. Raid 0 provides the greatest performance returns, but also carries the greatest risk because there are is no data redundancy for handling disk failures. Review the RAID level solutions and decide which is right for your data.
- For Temp, fault tolerance is not necessary. Hardware striping optimizes I/O speeds.
- Apart from implementing a good backup solution, fault tolerance is recommended for Data.
- Ensure that the Application, Data, or Temp files are not encrypted or compressed, which requires extra processor time.
- Ensure that the hard disk controller is not the bottleneck. For example, with IDE, it is faster to put one disk drive per channel as master. Therefore, do not put both of them on the same channel as master and slave, especially when you use software striping.
- If more than one hard disk is available, verify that Data is on a partition of one disk, and Temp is on a partition of another other disk.
- Verify that enough space is available on all partitions. Remember to take the Inventor Undo file into consideration.
- Do not place multiple page files on different partitions on the same physical disk drive, as this yields no benefit.

**CPU and Multicore**

You can gain some benefit from using multiple processors in Inventor. However, a faster, single processor can be more desirable. By design, Inventor is not a multi threaded application. The processing load cannot
ordinarily be balanced over multiple processors. However, some specific functionality in Inventor does support multicore technology.

Inventor supports multi-core operations in certain workflows. For details see *Support for multi-core processors*.

The wisest choice is to procure the fastest single CPU that your budget allows. If your budget allows, buy the two fastest dual CPUs.

**Hardware conflicts**

Use msinfo32 to see if there are any conflicts. In the System Information dialog box, go to Hardware Resources > Conflicts/Sharing.

Make a note of any devices that are conflicting, and update the drivers.

(Especially anything that is conflicting with the graphic card or network card.) Windows dynamically assigns IRQs, so updating drivers does not resolve these conflicts. However, it can help to manage conflicts better.

**Update drivers for other devices**

Run Device Manager, and determine the manufacturers for the following devices. Visit their website, and download and install the latest drivers/firmware, any of which can cause problems: ■ Hard Disk Drive ■ Hard Disk Controllers ■ CD-ROM|DVD Player/CD-R/RW drives ■ Monitors ■ Network Card ■ Sound Card ■ Keyboard ■ Mouse ■ 3D mouse (Space Mouse, Space Navigator, Space Pilot, and so on) ■ Any other peripheral device connected to the machine (printer, camera, digitizer, and so on)

**Physical memory fragmentation**

Working with any memory intensive application, the memory in your machine fragments in a similar way to a hard disk. RAM fragmentation causes the OS to take longer and longer to fulfill I/O requests, slowing the whole system. The most common resolution to this problem is to restart the machine as it starts to negatively affect performance. One alternative is the use of a RAM defragmentation utility that runs in Windows and automatically frees up RAM when fragmentation reaches alarm levels.
Pagefile
Always create the page file on a freshly formatted empty partition, ensuring that fragmentation is minimized.

Set both the minimum and maximum values for the page file size to the same value. The same value ensures that the whole amount of disk space is allocated in one go, minimizing fragmentation of the disk. It also guarantees memory allocation is not slowed down by resizing virtual memory.

Set the page file size equal to 1X to 1.5X actual RAM.

If the amount of virtual memory becomes disproportionate (5:1) compared to the amount of physical memory, performance suffers. The machine is perpetually reading and writing to disk.

Do not place multiple page files on different partitions on the same physical disk drive. Preferably, place them on a different partition or physical disk than the system (OS) files. For example, one page file on d: \.

Avoid having a page file on the same drive as the system files, such as the OS.

Avoid putting a page file on a fault-tolerant drive, such as a mirrored volume or a RAID-5 volume. Page files do not need fault-tolerance, and some fault-tolerant systems suffer from slow data writes because they write data to multiple locations.

Defragment the hard drive
Keeping your drive defragged results in an improvement in the open time of Inventor documents, especially large assemblies. When you copy or save large files to a fragmented drive, the files are fragmented and the open time degrades. The slower your disk, the more fragmentation affects performance. This factor is important when you migrate datasets to a new version of Inventor, or download datasets from the Vault or a network location to your machine for editing.

You can defragment using the tool installed with Windows, or you can use a commercial tool. The free tool is located under Start > Programs > Accessories > System Tools > Disk Defragmenter. You can improve the Inventor startup time by defragmenting the Inventor program modules installed on your hard disk. To defragment your Inventor program files only, use the following procedure:

1. Download the Contig tool from http://technet.microsoft.com/en-us/sysinternals/bb897428. Place the contig.exe program in a folder, such as C:\Windows or some other folder included in your PATH environment variable.
2. Start a command-line window - Start, Run, type CMD, press OK.
3. Change folders to the folder containing the Inventor program modules. For example: cd C:\Program Files\Autodesk\Inventor <version>\Bin
4. If you want to know whether the Inventor files are fragmented, run "Contig /a *.*"
5. If Contig reports that your files are averaging more than 1.5 fragments per file, defragment them. To defragment the files in the current folder and all subfolders, type: "Contig /s *.*"
6. Reboot.
If you still see slow startup times after defragmenting your drive, there can be a problem with your disk or input device configuration. For drive issues, work with your local IT department to benchmark your drive and determine if there is a configuration or driver problem. If you use a specialized input device made for CAD products, you can uninstall it and use a normal mouse to see if the divide is causing a problem. Installing a newer driver for your input device sometimes solves the problem.

**Disk cleanup**

Disk Clean up is a one-stop tool for removing unwanted and unnecessary files. It is useful to clear the Recycle bin, Temp files, old compressed files, and so on. Defragment the hard drive after running Disk Cleanup for maximum benefit. Access Disk Cleanup from Start>Programs>Accessories>System Tools>Disk Cleanup.

Regularly empty the temp folder and Recycle Bin. Go to Start>Control Panel>System>Advanced Tab>Environment Variables to find where the TEMP file is located.

Ensure that the OS, Inventor Application files, or, Inventor work files are NOT on a compressed or encrypted drive. **Operating System and Services**

**Windows themes and performance**

Inventor supports Windows 7, 8.1, and 10. Windows themes and visual effects may use system resources with little productivity benefit. Consider keeping them to a minimum.

**Antivirus software**

Minimize interference with Inventor by your AV software by reducing the security. Some antivirus software can disable Real-time file protection. We recommend that you configure it to scan only executables, and not every file that is opened.

**Services**

To free memory, turn off services that are not in use. Stopping unused services saves memory and improves system performance. However, make sure that you understand the consequences of stopping a service before you do so.

Services running on your machine that you rarely or never use, waste system resources. Manage services in the Windows Services dialog box. Click a service to display a description. Double click a service to display the Properties dialog box. On the Dependencies tab, see dependent and required services. If a service is not needed, change the startup type to Manual. Keep a note of any changes you make so that you can revert to the previous settings if necessary.

**Background applications**

Minimize the number of applications running in the background and in the Windows task bar.

**Network Environment**

Use a document management system such as Autodesk Vault Basic to copy the data to your local hard disk. Accessing data from your local hard drive gives you the fastest possible access during open, save, close, and updates.
Segregate engineering to its own LAN segment to:

- Increase stability and reduce unnecessary network bandwidth from other areas of the organization.
- Allow the engineering team to run at a full duplex 1-Gb speed without impacting other areas of the organization.

**Switches**

Lock all Engineering ports on switches to 1-Gb full duplex, and disallow auto-switching.

This action ensures that there is no interruption in the data flow across the LAN segment while large amounts of Inventor data are being used. When you use Inventor in a shared environment, this setting is vital to achieve a predictable and stable network.

**Network cards**

Lock all network cards to 1-Gb full duplex, and do not allow auto-detecting.

This action ensures that there is no interruption in the data flow across the LAN segment while large amounts of Inventor data are being used. When you use Inventor in a shared environment, this setting is vital to achieve a predictable and stable network.

**Data server**

Upgrade the Inventor file data server to handle anticipated peak load of engineering.

- Faster CPU
- Increased memory
- Multiple network cards

**Hops**

Ensure that there are no more than two hops between the workstation and the Inventor file server.

A simple method to check hops is to use the DOS command tracert from the client machine to the server. The tracert command lists the number of hops.

**LAN segment**

Ensure that the Inventor file server is on the same segmented LAN segment as the Inventor users.

**Monitor network usage**

Measure the network usage on both the Workstation clients and the Inventor file servers. Keep overall network usage at 40% or less on the server. If server network usage exceeds 40%, performance suffers, and the likelihood of data loss increases. Either upgrade the network, or restrict the number of users accessing the server.

If all users utilize the server at the same time, we recommend that you upgrade CPUs and memory for the server, and possibly multiple network cards and LAN segments.
Inventor uses segmented loading of files, which can cause issues when you work on files over the network. For example, you open an assembly file, and Inventor begins loading the b-reps (boundary representations) of each file, and you start editing some part files. The network then fails and you try to save, but cannot because the complete file did not transfer locally. It is then necessary to revert to an older version of the file. Therefore, we recommend that you work on local drives.

**To Increase Capacity of System Memory**

If you experience memory consumption issues when opening Autodesk Inventor models, refer to the following suggestions.

**General**

- Keep the modeling Level of Detail of purchased or library components to what is needed for accurate design (such as space envelopes, hole sizes, and locations). Adding unnecessary detail (such as textures, threads, coil features, fillets) can affect performance and capacity.
- Close all applications that you do not need opened when working with large assembly files to reduce page swapping with the hard drive.
- Unload any unnecessary add-ins before opening an assembly. Check the Add-In Manager to find out what is loaded on startup to determine if any can be unloaded. For example, do not load Routed systems: Cable and Harness on startup if it is not required.
- Consider not placing hardware parts at all, or only place one instead of many. Quantity overrides can be performed on the Bill of Materials and Parts List to accurately capture the required number of fasteners and other hardware in a design.
- Make it a practice to purge all unused style definitions. Each time a material or color change occurs, the file caches the style definition. If the file is referenced many times in an assembly, the unused definitions can have an impact on memory. An external style library stores material, light, and color style definitions, so maintaining more than one local, cached definition is not necessary. To purge unused style definitions, select Manage tab ➤ Styles and Standards panel ➤ Purge.
- Use Selection commands to hide or suppress sets of components based on such factors as size or on internal components that are not seen. Note that BOM reports remain accurate regardless of component suppression.

**Parts**

- Suppress large feature patterns on parts. Consider using a bitmap texture in place of large feature patterns.
- Reduce unnecessary details in parts. For example, do not model physical threads, fillets, and gear teeth if the detail is not required for manufacturing.
- Minimize the usage of Move Bodies in a multi-body part. Use click to add to group moves into one feature whenever possible.
Assemblies

■ Use only enough assembly constraints to achieve the required component position or motion.

■ Avoid redundancy. Use the Application Option **Enable relationship redundancy analysis** to check for redundant constraints. Turn off the option after completing the analysis.

■ Minimize the use of assembly features.

■ Use a common constraint reference if possible. Constraining all components to a common component or geometry improves performance and reduces complexity. For example, use the Origin work features to constrain components in an assembly whenever possible.

■ Use a common origin for static assemblies using skeletal modeling.

■ Constrain symmetrical assemblies to mid-planes or center axes.

■ Locate and fix or suppress any constraint errors. Use the Design Doctor to isolate components.

■ Use iMates to reduce overhead and enforce consistency.

■ Use component patterns whenever possible.

■ Use Design View representations of large assemblies to display only the components needed for the current tasks. This improves graphics performance.

**TIP** Create Design View representations using specific colours for sub-systems to make them easy to distinguish and manage.

■ Use Level of Detail Substitute representations to replace the entire assembly with a single part file in the same assembly file. The substitute part can be any part file on disk. A substitute surface composite part created using the Shrinkwrap or Derived Component command significantly reduces the memory requirements and file size of an assembly.

■ Use Level of Detail representations to suppress components that are unnecessary for the current task. This reduces the amount of memory in use. Consider creating an LOD from the bottom-up. For example, open an assembly with “All Parts suppressed” and then unsuppressed the parts and components in need.

■ As components are added to an assembly, suppress the components that are not necessary for constraining or locating new components.

■ Turn off the Contact Solver after performing a contact analysis.

■ Whenever possible, turn off the visibility of Coils and Springs in assembly files.
■ Turn off Adaptive. Use the Flexible option if the component must adapt to a new position.

■ Consider using Grip Snap to position components accurately, and then ground them.

Drawings

■ Keep the size of drawing files as small as possible by minimizing the numbers of views on a sheet. For example, have one base view of the main assembly, and no more than 4 other projected, detailed, or section views.

■ Minimize the number of sheets in a drawing file.

■ Before inserting a .bmp into a title block, make sure the .bmp is saved in the smallest file size permitted by your company's standards. In Microsoft Paint, the default file type is 24-bit Bitmap. Reducing the file type to 16 Color or Monochrome type Bitmap, will increase capacity.

■ In the Drawing tab in Document Settings, set Always in Bitmap Resolution drop-down menu with a low bitmap resolution to help reduce memory consumption when working with large or complex models of shaded views.

Additional Information.

Autodesk forum link on popular discussion on graphics card.

https://beta.autodesk.com/project/forum/thread.html?cap=fb14413735ee42c99624e3793b19a0b2&fo
rid=%7B28691bb6-fd44-4cd0-9ee8-68da6ed18a1c%7D&topid=%7B2c326be1-274d-4d2a-bb78-
e984a113b9fc%7D&tp=2&to=asc&ts=last&tl=15&tv=desc#toppost