System Requirements

Feb 12, 2014


Autodesk DLM is compatible with these Internet browsers:

  • Internet Explorer 7, 8, and 9
  • FireFox 3.6 or later
  • Chrome 12 or later

Autodesk DLM can be installed on the following Windows operating systems.

Note: Administrator privileges are required to install DLM.
Platform Minimum Service Pack Requirement
Windows XP 32-bit Home or Professional Edition SP3
Windows XP 64-bit Professional SP2
Windows 7 32-bit Starter, Home Basic, Home Premium, Professional, Ultimate or Enterprise Base
Windows 7 64-bit Home Premium, Professional, Ultimate, or Enterprise Base
Windows 8 32- or 64-bit Enterprise Base
Windows Server 2008 64-bit R2 Base
Windows Server 2008 32- or 64-bit SP1
Windows Server 2003 32- or 64-bit R2 SP1
Windows Server 2003 32- or 64-bit SP1
Windows Server 2012 64-bit Base

Display Resolution

DLM requires a minimum resolution of 1024 x 768 pixels.

Discuss