Inventor optimalization for large assemblies

Feb 12, 2014  |  In-Product View

Hardware and system recommendations

General

Recommended for large assemblies:
  • Win7 x64 (Ultimate, Enterprise, or Professional).
  • Dual Six core processor (12 cores total, hyperthreading not recommended because Inventor does not take advantage (except Studio rendering)).
  • 24 GB or more system RAM.
  • DirectX 11 level graphics card with 2 GB or more video RAM (CAD workstation-class graphics card ).
  • Two (or more) 1-TB hard disk drives, SATA, SAS, Ultra 160 and Ultra 320 SCSI, SSD, RAID 0 or 1, 7200 RPM or better.
Minimum for large assemblies:

Adding more RAM to your system provides better performance and capacity. The following table provides a general guideline for the recommended amount of RAM. Actual requirements vary depending on complexity of part geometry and number of occurrences.

Number of unique parts Recommended RAM in GB
> 5000 6
> 10,000 12
> 15,000 18
> 20,000 24

Motherboards

To simplify searching for updates drivers\BIOS\Chipset Utilities, choose a motherboard that uses a chipset made by the same manufacturer. When selecting a CPU, consider the onboard memory cache. The amount and type of onboard cache can significantly affect performance.

Use a motherboard that uses a chipset of Intel or AMD. The chipset utilities of some other manufacturers can possibly present stability problems due to their implementation of the AGP interface. In this situation, you can uninstall them and rely on the generic windows drivers, which can adversely affect performance. Open a dialogue with the manufacturer to resolve this situation.

Even new machines rarely have the latest available BIOS from the manufacturer website. Download and update it.

Graphic cards

Ensure that you have the latest driver and BIOS installed.

Keep the PCI slot next to the AGP (graphic card) slot on the motherboard free if possible. Many newer graphic cards come fitted with a fan that prohibits the use of the first PCI slot. They generate excessive heat that can cause issues for a PCI card placed next to them. They also use the same motherboard infrastructure, resulting in IRQ conflicts.

Autodesk certified graphics hardware: http://usa.autodesk.com/adsk/servlet/cert?siteID=123112&id=16391880

RAM

The more RAM you have installed in your machine, the better. Check the motherboard spec to see the maximum amount of RAM that can be installed. Use the fastest RAM available.

Number of unique parts Recommended RAM in GB
> 5000 6
> 10,000 12
> 15,000 18
> 20,000 24

Intel Systems - choose RD-Ram or DDR RAM (RAMBUS) modules preferably. Similarly, AMD Systems - choose DDR RAM. Choose RAM that transfers data at the same frequency as the processor. For example, PC1066 RAM delivers data at 2,132 MB/sec which is the same as Intel 850E. Pairs deliver 4.2Gbytes/sec. A P4 CPU @ 533 MHz also works at 4.2GBytes/sec..

Use Memprobe.exe to obtain detailed information on how your system RAM is being used. This utility is located in C:\Program Files\Autodesk\Inventor <version>\Bin\. When working with Memprobe.exe, add the Inventor Working Set and the System Working Set then compare to the Hardware value.

Hard disk drive configuration

Organizing HDDs:

For the purposes of this section we can state that information stored on a computer hard disk can fall into one of the following four categories. Each category has a different requirement:

  • OS = Operating System
  • Application = Inventor application
  • Data = Inventor data files (ipt, iam, idw files and the Workspace)
  • Temp = Pagefile, undo and temp files

In the most basic scenario these items are located on one or two partitions of the one physical disk in the system. In an ideal situation, they are on multiple volumes, where Temp is striped and Data is striped with fault tolerance.

There are a couple of reasons to separate these files:
  • Data Access

    Files located in OS and Applications are accessed frequently (when a program is started the files are loaded once into memory). Files located in Data and Temp are read and written often while you work with Inventor. So, the greatest benefit comes from increasing the read and write access speed to Data and Temp by using faster hard drives.

  • Fragmentation

    This is closely linked to Data Access. As files are heavily used, they fragment faster.

Separating the OS and applications is cosmetic, and does not result in much difference in performance.

Putting the Temp files on a separate partition ensures that they do not cause fragmentation of other files. To eliminate fragmentation easily, delete all files in the system Temp folder after closing all applications. Set the minimum pagefile size to the same value as the maximum pagefile size to increase performance when paging to disk. The pagefile does not fragment or cause fragmentation of other files. Also, as the pagefile is already set to the maximum size, no time is wasted expanding it. Create the pagefile first on the empty partition. Then it does not fragment, and there is no need to delete and recreate it.

Solid-state drives can improve performance for large assemblies. Hard drive read/write times affect the time required to open or save an assembly . Solid-state drives can improve this performance.

Inventor uses segment loading when accessing files, which means that only the required parts of the file are loaded in memory. The rest remains on the hard drive. Consequently, when additional segments from the file are required, it is beneficial if they can be read as fast as possible.

Follow these suggestions to improve performance:

  • Ensure the OS\Applications & Data\Temp reside on different physical disks, at the least different partitions.
  • Consider that the biggest performance gain is obtained in improving the speed with which Data and Temp are accessed. If you have multiple disks available, you can use software RAID (Redundant Array of Inexpensive Disks), striped volumes, to increase the performance. (Combine two disks into a striped volume and put your Data files on it.) Do the same for Temp. To attain even better performance and fault tolerance, consider the use of a hardware RAID solution.
  • For Temp, fault tolerance is not necessary. Hardware striping optimizes I\O speeds.
  • Apart from implementing a good backup solution, fault tolerance is recommended for Data.
  • Ensure that the Application, Data, or Temp files are not encrypted or compressed, which requires extra processor time.
  • Ensure that the hard disk controller is not the bottleneck. For example, with IDE, it is faster to put one disk drive per channel as master. Therefore, do not put both of them on the same channel as master and slave, especially when you use software striping.
  • If more than one hard disk is available, verify that Data is on a partition of one disk, and Temp is on a partition of another other disk.
  • In general SCSI is faster than IDE, as it does not have the CPU overhead of IDE.
  • Verify that enough space is available on all partitions. Remember to take the Inventor Undo file into consideration.
  • Do not place multiple pagefiles on different partitions on the same physical disk drive, as this yields no benefit.

Dual processors

You can gain some benefit from using multiple processors in Inventor. However, a faster, single processor can be more desirable. By design, Inventor is not a multi threaded application. The processing load cannot ordinarily be balanced over multiple processors. However, some specific functionality in Inventor does support multi-core technology.

The wisest choice is to procure the fastest single CPU that your budget allows. If your budget allows, buy the two fastest dual CPUs.

Hardware conflicts

Use the System Information dialog box to determine any hardware conflicts. Use winmsd for Windows XP. In the System Information dialog box, go to Hardware Resources > Conflicts/Sharing.

Make a note of any devices that are conflicting, and update the drivers. (Especially anything that is conflicting with the graphic card or network card.) Windows dynamically assigns IRQs, so updating drivers does not resolve these conflicts. However, it can help to manage conflicts better.

Update drivers for other devices

Run Device Manager, and determine the manufacturers for the following devices. Visit their website, and download and install the latest drivers\firmware, any of which can cause problems:
  • Hard Disk Drive
  • Hard Disk Controllers
  • CD-ROM|DVD Player\CDR\RW drives
  • Monitors
  • Network Card
  • Sound Card
  • Keyboard
  • Mouse
  • 3D mouse (Space Mouse, Space Navigator, Space Pilot, and so on)
  • Any other peripheral device connected to the machine ( printer, camera, digitizer, and so on)

Physical memory fragmentation

Working with any memory intensive application, the memory in your machine fragments in a similar way to a hard disk. RAM fragmentation causes the OS to take longer and longer to fulfill I\O requests, slowing the whole system. The most common resolution to this problem is to restart the machine as it starts to negatively affect performance. One alternative is the use of a RAM defragmentation utility that runs in Windows and automatically frees up RAM when fragmentation reaches alarm levels.

Pagefile

Always create the pagefile on a freshly formatted empty partition, ensuring that fragmentation is minimized.

Set both the minimum and maximum values for the pagefile size to the same value. The same value ensures that the whole amount of disk space is allocated in one go, minimizing fragmentation of the disk. It also guarantees memory allocation is not slowed down by resizing virtual memory.

Set the pagefile size equal to 1X to 1.5X actual RAM.

If the amount of virtual memory becomes disproportionate (5:1)compared to the amount of physical memory, performance suffers. The machine is perpetually reading and writing to disk.

Do not place multiple pagefiles on different partitions on the same physical disk drive. Preferably, place them on a different partition or physical disk than the system (OS) files, For example, one pagefile on d:\.)

Avoid having a pagefile on the same drive as the system files, such as the OS.

Avoid putting a pagefile on a fault-tolerant drive, such as a mirrored volume or a RAID-5 volume. Pagefiles do not need fault-tolerance, and some fault-tolerant systems suffer from slow data writes because they write data to multiple locations.

Defragment the hard drive

Keeping your drive defragged results in an improvement in the open time of Inventor documents, especially large assemblies. When you copy or save large files to a fragmented drive, the files are fragmented and the open time degrades. The slower your disk, the more fragmentation affects performance. This factor is important when you migrate datasets to a new version of Inventor, or download datasets from the Vault or a network location to your machine for editing.

You can defragment using the tool installed with Windows, or you can use a commercial tool. The "free" tool is located under Start > Programs > Accessories > System Tools > Disk Defragmenter. You can improve the Inventor startup time by defragmenting the Inventor program modules installed on your hard disk. To defragment your Inventor program files only, use the following procedure:

  1. Download the "Contig" tool from http://technet.microsoft.com/en-us/sysinternals/bb897428 . Place the contig.exe program in a folder, such as C:\Windows or some other folder included in your PATH environment variable.
  2. Start a command-line window - Start, Run, type "CMD", press OK.
  3. Change folders to the folder containing the Inventor program modules. For example: "cd C:\Program Files\Autodesk\Inventor <version>\Bin"
  4. If you want to know whether the Inventor files are fragmented, run "Contig /a *.*"
  5. If Contig reports that your files are averaging more than 1.5 fragments per file, defragment them. To defragment the files in the current folder and all subfolders, type: "Contig /s *.*"
  6. Reboot.

If you still see slow startup times after defragmenting your drive, there can be a problem with your disk or input device configuration. For drive issues, work with your local IT department to benchmark your drive and determine if there is a configuration or driver problem. If you use a specialized input device made for CAD products, you can uninstall it and use a normal mouse to see if the devide is causing a problem. Installing a newer driver for your input device sometimes solves the problem.

Disk Cleanup

Disk Cleanup is a one-stop tool for removing unwanted and unnecessary files. It is useful to clear the Recycle bin, Temp files, old compressed files, and so on. Defragment the hard drive after running Disk Cleanup for maximum benefit. Access Disk Cleanup from Start>Programs>Accessories>System Tools>Disk Cleanup.

Regularly empty the temp folder and Recycle Bin. Go to Start>Control Panel>System>Advanced Tab>Environment Variables to find where the TEMP file is located.

Ensure that the OS, Inventor Application files, or, Inventor work files are NOT located on a compressed or encrypted drive.

OEM Versions of Windows

If Windows came pre-installed on your machine it is possible that is has been "tweaked" by the manufacturer. If it was not set up to use DMA access for all IDE drives, the alternative PIO mode is very CPU intensive. The first device on the primary channel is the main hard disk, It is usually configured correctly, but check the slave drives and devices on the secondary channel.

In Device Manager, click "IDE ATA\ATAPI controllers". Right Click "Primary IDE Channel." Then click the "Advanced Settings" tab, and change the Transfer Mode to "DMA if available".

Windows Themes and Performance

Windows themes and visual effects use system resources with little productivity benefit. Keep them to a minimum.

Set the Visual Effects to "Adjust for best performance":
  • Windows XP: Control Panel > System > Advanced > Performance settings
  • Windows 7: Control Panel > System and Security > System > Advanced system settings. On the Advanced tab, click the Settings button in the Performance area.
Use the Classic Theme to minimize OS graphics requirements:
  • Windows XP: Control Panel > Display > Themes
  • Windows 7: Control Panel > Appearance and Personalization > Personalization
Turn off Sidebar/Desktop Gadgets in Windows 7:
  • Control Panel > Appearance and Personalization > Desktop Gadgets

Anti-Virus Software

Minimize interference with Inventor by your AV software by reducing the security. Some antivirus software can disable "Real-time file protection". We recommand that you configure it to scan only executables, and not every file that is opened.

Clean Up your Registry

Regedit is a bare-bones registry editing tool that comes pre-installed with Windows. There are numerous tools available that perform this task better.

Services

To free memory, turn off services that are not in use. Stopping unused services saves memory and improves system performance. However, make sure that you understand the consequences of stopping a service before you do so.

Services running on your machine that you rarely or never use, waste system resources. Manage services in the Windows Services dialog box. Left click a service to display a description. Double click a service to display the Properties dialog box. On the Dependencies tab, see dependent and required services. If a service is not needed, change the startup type to "Manual". Keep a note of any changes you make so that you can revert to the previous settings if necessary.

Background applications

Minimize the number of applications running in the background and in the Windows task bar.

Network environment

Use a document management system such as Autodesk Vault Basic to copy the data to your local hard disk. Accessing data from your local hard drive gives you the fastest possible access during open, save, close, and updates.

Segregate engineering to its own LAN segment to:
  • Increase stability and reduce unnecessary network bandwidth from other areas of the organization.
  • Allow the engineering team to run at a full duplex 1-Gb speed without impacting other areas of the organization.

Switches

Lock all Engineering ports on switches to 1-Gb full duplex, and disallow auto-switching.

This action ensures that there is no interruption in the data flow across the LAN segment while large amounts of Inventor data are being used. When you use Inventor in a shared environment, this setting is vital to achieve a predictable and stable network.

Network Cards

Lock all network cards to 1-Gb full duplex, and do not allow auto-detecting.

This action ensures that there is no interruption in the data flow across the LAN segment while large amounts of Inventor data are being used. When you use Inventor in a shared environment, this setting is vital to achieve a predictable and stable network.

Data Server

Upgrade the Inventor file data server to handle anticipated peak load of engineering.
  • Faster CPU
  • Increased memory
  • Multiple network cards

Hops

Ensure that there are no more than two hops between the workstation and the Inventor file server.

A simple method to check hops is to use the DOS command "tracert" from the client machine to the server. The trecert command lists number of hops.

LAN Segment

Ensure that the Inventor file server is on the same segmented LAN segment as the Inventor users.

Optimize Network Performance

If you work in a shared environment, and the bottleneck is not Inventor or the OS but the network, you can improve network traffic speed. Set the I\O page lock limit to improve performance of the system. Depending on your system configuration, a page lock limit between 8 and 16MB is a good choice.

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

Add a new DWORD entry named "IOPageLockLimit". Enter limit size in Byte that is, 12MB = 12582912 Bytes (=12 x 1024 x 1024).

Monitor Network Usage

Measure the network usage on both the Workstation clients and the Inventor file servers. Keep overall network usage at 40% or less on the server. If server network usage exceeds 40%, performance suffers, and the likelihood of data loss increases. Either upgrade the network, or restrict the number of users accessing the server.

If all users utilize the server at the same time, we recommend that you upgrade CPUs and memory for the server, and possibly multiple network cards and LAN segments.

Inventor uses segmented loading of files, which can cause issues when you work on files over the network. For example, you open an assembly file, and Inventor begins loading the b-reps (boundary representations) of each file, and you start editing some part files. The network then fails and you try to save, but cannot because the complete file did not transfer locally. It is then necessary to revert to an older version of the file. Therefore, we recommend that you work on local drives.

Tools and Methodologies

Project files

Project files organize Inventor data, and determine the location of the working data, templates, styles, and libraries.

Never locate a Workspace on a network location. It is intended to be located on local machines. Perform all work on files held locally and copied back to the network when finished. If you do not, performance implications occur when you save all data across the network. Make the workspace local to each user machine.

Never define Workgroup or Library locations that point to subfolders of the Workspace or another Workgroup or Library.

For Example:
  • Workspace - C:\Damper
  • Workgroup - C:\Damper\Section1

If the Workgroup or Library location is a subfolder of another defined location, Inventor highlights the offending path in red. You can still save the project file. It is a warning that the location does not produce the most efficient file structure.

The fewer workgroup search paths defined, the better. Fewer search paths improves searches for files. Make your assembly structure flat. For example, if you have an assembly file in a folder, place all .idws of that .iam in the same folder. In a subfolder, place all the components in the .iam. Inventor uses the "Subfolder Path" to locate the components it needs. If Inventor cannot find components immediately, it continues searching, which has a negative effect on performance.

For more information: Projects

Application Options

The table contains recommended Application Options that affect assembly performance.

Tab Option Large Assembly Setting
General Show command prompting off
  Enable Optimized Selection on
  Undo File Size 1000 MB
Colors Background 1 Color
  Enable Prehighlight Off
Display Display Quality Rough
  View transition time 0
  Minimum frame rate 10
  Show Origin 3D Indicator Off
  Show Origin XYZ axis labels Off
Hardware Performance On
Drawing Retrieve model dimensions Off
  Display line weights Off
  Show preview as Bounding Box
  Section View Placement as Uncut On
  Enable background updates On
Notebook Note icons Off
Sketch Autoproject edges for sketch creation and edit Off
Assembly Defer Update On
  Enable Constraint Redundancy Analysis Off
For more information: Application Options settings.

Assemblies

Resolve all constraint errors

Ensure that all errors related to constraints are resolved. Open ALL subassemblies first, and resolve the problem in the subassemblies. Then open the main assembly, and address any errors. In a large assembly, it is time-consuming to attempt to resolve constraint errors in lower-level subassemblies.

Work Geometry

Turn off the visibility of unnecessary work planes, axes, and points. The visibility of too many work features in an assembly can affect the performance. To turn off all work geometry quickly, use View > Object Visibility.

Complex Features

Standardize on an amount of detail required to finish the design. Sometimes small components have exceptionally high amounts of detail in the top level assembly. Standardizing on a simpler amount of detail increases performance and capacity. You can create parts that require higher levels of detail when necessary. We recommend that you create these parts only when the part meets some predetermined requirements. Then engineers can model only what is required to complete the design.

Coils or spring shaped parts can be resource intensive. Either replace these parts with simpler shapes, or turn off the visibility, especially in drawings.

Similarly, it is not always necessary to display in full detail purchased parts, such as standard components (motors, actuators) externally sourced and inserted into an assembly. Typically, the internal workings or details of purchased components are not necessary to complete your design.

Error Handling

Warnings- Inventor displays warnings when there is a problem.

Try to remove warnings from an assembly before integrating it into production designs by using the Design and Sketch Doctors. Missing references and constraint failures are key warnings, and affect Inventor performance. While you can work with missing parts and failed constraints, it is not good practice to do so for extended periods of time. Inventor finds that something is sick, performs an audit, and updates it every time you switch back to that file. If all errors are removed, assemblies behave more predictably and performance increases.

Turn Off All Adaptivity

Leaving adaptivity turned on can reduce the responsiveness of Inventor. The adaptive components are frequently checked for recomputation. Therefore, turn off adaptivity after a design is complete, and turn it back on when design changes are necessary.

Standard Parts

For standard parts that do not change, consider placing them in a project library folder. Inventor searches these parts in a different way than normal parts. Do not change the name of an existing library folder. A change in the name requires that you resolve each part in the library.

For more Assembly tips see: Increase performance and capacity

Assembly constraints

Fully constrain components or ground components that are not designed to move in your assembly. Assembly constraints require the software to perform a calculation. When there are many components in an assembly and each component has multiple assembly constraints, these calculation times often become significant.
  • Avoid redundant constraints. Use the Application Option "Enable constraint redundancy analysis" to find redundant constraints, then turn off the option.
  • Use a common constraint reference if possible.
  • Use Common Origin skeletal modeling for static assemblies. The productivity tools Place at Component Origin and Ground and Root are useful for Common Origin skeletal modeling.
  • Use the Design Doctor to find any constraint errors and fix the errors.
  • Turn off Adaptivity when not using it to design. Use Adaptivity for parts, and Flexible for exercising degree of freedom of subassemblies.

For more information: Assembly constraints overview

Level of Detail representations

Using Level of Detail representations, you manage which components are loaded into memory. You also manage the memory consumption of the software. Level of Detail representations suppress components (parts or subassemblies) in an assembly. The suppressed components are not loaded into memory.

Use LOD representations when opening assembly files so that only the necessary components are loaded into memory. For more information: Level of Detail representations

Substitute Level of Detail representations

Assembly substitutes are a type of Level of Detail (LOD) representation. A substitute uses a single part file to represent an entire assembly.

There are three methods for creating substitute LODs:
  • Derive Assembly uses the Derive command to create a part file to represent the assembly.
  • Shrinkwrap uses the Shrinkwrap command to create a part file to represent the assembly.
  • Select Part File allows you to browse and select a part file to represent the assembly.

Drawings of large assemblies

Use View representations and LOD representations to control the amount of detail in drawing views. Even if some of the bodies are occluded in the final drawing view, the data is still loaded into memory to compute them unless representations are used.

In Application Options, Drawing tab, enable the background updates option. This option displays a representation of the view before it is calculated. You can continue working in the drawing, and dimension the view, while the view calculates.

Avoid or reduce the use of property overrides at the edge level. Use feature, body, or component level overrides instead whenever possible.

In the Document Settings dialog box, Drawing tab:
  • Turn on Defer Update mode to reduce unnecessary updates to the drawing. When Defer Update is active, view creation commands and some annotation commands are not available.
  • Set Use Bitmap to Always, and use the lowest resolution that provides the desired result. With this setting active, the software uses a cached bitmap image for shaded views instead of rendering the actual shading

For more information: Develop drawings_for large assemblies

Engineers Notebook

The Engineers Notebook is useful for communicating design intent. When you create a note that contains an image, a bitmap embeds into the .ipt or .iam file and increases the file size. The larger the file size, the more hardware resources are used. Therefore, restrict the use of notes with images to minimize file size.

The Engineers Notebook is also in its own segment in memory, which loads only if notes are present. With no notes, the segment does not load, requiring fewer resources.

For more information: Engineers Notebook

Link Parameters

If you share parameters between parts, do not link them by an Excel spreadsheet. When the Excel file changes, the software cannot determine which files are affected, so an update is required for all parts. The performance of large assemblies slows down. Instead, use the derive command to link the parameters into the parts. With this method, the software detects and updates only those files that a change affected.

For more information: Parameters in models

Known support issues

Support issues are listed on the Autodesk Services and Support site.

Discuss