Render material images are missing in the material browser in Revit

Autodesk Support

Mar 16, 2025


Products and versions covered


Issue:

Materials in Revit are not displaying inside the model as expected, and the material images are missing within the material browser.  Missing Material in the Browser 

Causes:

  • The Render Appearance image files are part of the Material Library, but not saved into the Revit file.
  • Even using eTransmit will not include these images: File Types Not Included When Transmitting a Model.
  • Custom images not stored in common folders/shared network accessible to all users

Solution:

To resolve the issue, follow the steps below:

Additional Render Appearance Path'

  1. Collect all custom images in a specific folder on a shared network location that everyone can access.
  2. In the 'Revit > Options > Renderings' dialog box, add the path of the required folder to the 'Additional Render Appearance Paths' field 

        Revit Options Dialogue box 

Note: After assigning the correct path, it may be necessary to select and assign at least one bitmap from the new location to the existing material appearance 

Users on Shared Network

Ensure the required folder has the necessary permissions. Additionally, if it is a cloud drive like OneDrive, verify that the folder is synced to the system

Products:

Revit Product Family;


Was this information helpful?


Need help? Ask the Autodesk Assistant!

The Assistant can help you find answers or contact an agent.


What level of support do you have?

Different subscription plans provide distinct categories of support. Find out the level of support for your plan.

View levels of support